Are there no NVMe drivers in LEDE?

I'm using LEDE 17.01

I installed my Samsung NVMe SSD, however LEDE is not able to load a driver for it automatically.
Is there a package I need to install, or is it simply not implemented yet?

Here's the output from lspci -knn below

 01:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd Device [144d:a804]
         Subsystem: Samsung Electronics Co Ltd Device [144d:a801]

And since there are no drivers fdisk can not see it as you can imagine.

Kind regards.

Do you have the correct kmod-ata modules installed?[Name_pkg-dependencies*~]=-ata

Doesn't kmod-ata only support AHCI?
The NVMe drive I have uses the NVMe protocol.

I can double check when I get access to the board again soon, however I'm pretty sure LEDE x86_64 installations come with kmod-ata since the SATA drives worked without needing to install any extra drivers.

S-ATA just works, have an APU2 with S-ATA running OpenWrt.

Looks like you need to add CONFIG_BLK_DEV_NVME=y to your kernel config.

Thanks, Dizzy.

I'll need to recompile the kernel later then.
I'll update this topic if it worked or not when I get to it.

Let us know, would be neat to have this enabled by default in the x86 kernel, since there will be more people using NVMe drives in the future no doubt.

I think I've recompiled the kernel(s?) with the extra value using the LEDE-SDK.
However after manually setting # CONFIG_BLK_DEV_NVME is not set to: CONFIG_BLK_DEV_NVME=y it sets it back to # CONFIG_BLK_DEV_NVME is not set and doesn't seem to compile the module as you can imagine.

Am I doing something wrong here?
Perhaps there's a makefile that needs to be ran to enable this through a menu perhaps?
I'm kind of stuck here..

make kernel_menuconfig

Inside of the lede-sdk-17.01.4-x86-64_gcc-5.4.0_musl-1.1.16.Linux-x86_64 directory when I run make kernel_menuconfig I get the following:

$ make kernel_menuconfig
make[1]: Entering directory '/media/ZFS-HGST-3TB-Mirror/Source-Repos/lede-sdk-17.01.4-x86-64_gcc-5.4.0_musl-1.1.16.Linux-x86_64/target/linux'
make[1]: *** No rule to make target 'menuconfig'.  Stop.
make[1]: Leaving directory '/media/ZFS-HGST-3TB-Mirror/Source-Repos/lede-sdk-17.01.4-x86-64_gcc-5.4.0_musl-1.1.16.Linux-x86_64/target/linux'
/media/ZFS-HGST-3TB-Mirror/Source-Repos/lede-sdk-17.01.4-x86-64_gcc-5.4.0_musl-1.1.16.Linux-x86_64/include/ recipe for target 'kernel_menuconfig' failed
make: *** [kernel_menuconfig] Error 2

This is why I manually edited the config-4.4 and config-3.4 files to have the CONFIG_BLK_DEV_NVME=y value.
Am I in the incorrect directory, or do I need to download some sort of submodule via Git?