Are there any /etc/config differences between 15.05 and current snapshot?

Dear All,

Are there any differences in the /etc/config files between Chaos Calmer 15.05 and the current snapshot, specifically regarding VLANs?

I ask because I've copied the VLAN setup in /etc/config/network and /etc/config/wireless to a new AP I'm trying to add OpenWrt support for, and the VLANs aren't working.

It's either because the new firmware I've compiled doesn't fully support my hardware, of I've got something wrong in the VLAN config.

Previously to add a new VLAN and associate it with an SSID, I've done this:
/etc/config/network:
config interface 'vlan30'
option proto 'static'
option ifname 'eth1.30'
option type 'bridge'
option delegate '0'

And for the wireless:
/etc/config/wireless:
config wifi-iface
option device 'radio0'
option network 'vlan30'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2'
option key 'myPassword'

This device is different from my other devices in that it has two eth ports. Eth1 is the PoE LAN which I am using. I cannot access the switch in this device for eth[0,1] (yet), so perhaps that is the issue with the VLAN tags getting dropped?

Tim

I did not find any differences when I upgraded, but your device could be different.

Thank you, unfortunately it's looking like it may be a hardware issue with this device's internal switch:

Looks like I'll have to wait a bit :slight_smile:

Tim

Ok? Does this mean, you have tested this with the device original firmware? And it too malfunctions in the same situation as well? Well, darn. That's sort of funny :smile: in a bad way :frowning: . The internal-switch is a evolution of the QCA8337. So you would think they have ironed out most of these bugs by now.

My bad - sometimes meaning goes awry in text :non-potable_water: :slight_smile:

I don't think my device is broken; I tried the broken version of OpenWrt Netgear put on it for a little bit, but the web gui is so slow and convoluted I gave up and took it apart, saw the UART header and started experimenting with it. I can see the tagged packets arriving at the port, they just don't go anywhere after that.

My previous device was definitely broken (after I got ahead of myself and tried flashing it, but instead overwrote the uboot partition causing a brick - thank god for 'lifetime warranty's'!).

Tim

This description of your problem there really sounds familiar.

About the "I can see the tagged packages arriving at the port". Do you mean you see the RX counter go up? Or More like tcpdump(-mini) picks them up on the eth1 interface too. Because if it's the latter, you could try what happens if you ditch the (known bad) port-mapping stuff completely and only use vlan.

This requires a patch to the essedma driver:
https://github.com/chunkeey/LEDE-IPQ40XX/commit/a04cf208fe317074502f7ea81dafa828c89b74bb#diff-7f93633c3954b7f1cdc325d9aa9219ab

Furthermore, you'll have to change you device's dts just like this patch does it for the qcom-ipq4019.dtsi.
(Set qcom,num_gmac to 1, set gmac0's vlan_tag to <1 0x3f>) and edit your device's 02_network entry
to something like:

ucidef_add_switch "switch0" "0t@eth0" "1:lan" "2:lan" "3:lan" "4:lan" "5:wan"

(This will also allow you to freely reassign the lan/wan ports)

(Last but not least, nowadays it might also be necessary to disable this line
https://github.com/openwrt/openwrt/blob/master/target/linux/ipq40xx/patches-4.14/710-net-add-qualcomm-essedma-ethernet-driver.patch#L216 as well)

Thank you - Yes, I was using tcpdump on the main eth1 interface to see the packets arriving from the WiFi interface with the vlan tag, but the RX counters on eth1.30 (my vlan) never moved above 0.

I'm away for a couple of weeks now, but I'll try it out on my return.

The switch in my device isn't visible from openWrt at present though. Does that matter?

Many thanks,

Tim

I'm back!

I tried your modifications above and copied the switch configuration from qcom-ipq4019.dtsi and I can now see the internal switch, but it's still stripping the VLAN tags.
Here's the output from swconfig regarding the switch it's found:

So, if it can see the switch and the VLANs are configured properly (and the line https://github.com/openwrt/openwrt/blob/master/target/linux/ipq40xx/patches-4.14/710-net-add-qualcomm-essedma-ethernet-driver.patch#L216 is commented out), how are my VLAN tags disappearing?

I'm testing the VLAN tags by doing this on my device:
/etc/init.d/firewall stop
ifconfig eth0.2 192.168.1.20 netmask 255.255.255.0 up
ping -I eth0.2 192.168.1.12

And on my desktop:
ifconfig enp4s0.2 192.168.1.20 netmask 255.255.255.0 up
tcpdump -i enp4s0 -w /home/tim/wac510.pcap

But all I'm seeing is:
11:30:10.330268 ARP, Request who-has 192.168.1.12 tell 192.168.1.20, length 46
11:30:10.330280 ARP, Reply 192.168.1.12 is-at 68:05:ca:2e:34:19 (oui Unknown), length 28
11:30:11.389374 ARP, Request who-has 192.168.1.12 tell 192.168.1.20, length 46
11:30:11.389383 ARP, Reply 192.168.1.12 is-at 68:05:ca:2e:34:19 (oui Unknown), length 28
11:30:12.429342 ARP, Request who-has 192.168.1.12 tell 192.168.1.20, length 46
11:30:12.429355 ARP, Reply 192.168.1.12 is-at 68:05:ca:2e:34:19 (oui Unknown), length 28
11:30:12.949798 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from a0:40:a0:7b:b7:6f (oui Unknown), length 300

So, the ARP broadcast is getting through with no VLAN tag, but it never receives the reply because it's getting sent back with no VLAN tag..?

What to do next? Or can I donate this device to someone who knows more about this than I do :slight_smile:

Tim