Archer MR200 wan and 4G LTE failover - Question configure networks devices VLANs

Hi everybody,

Earlier this week I had some excellent help from a openwrt guru on this site who helped me configure a TP-Link RE650 range extender to talk to my Ubiquiti ER-X upstream router. All good and it works although the bandwidth on the SSID are half the speed of the actual Ubi ER-X. here are the details for those interested: Question: Configure networks ( new lan devices, f/w, routing ) on TP-Link RE650 / openwrt 23

  • What do I want to do now?

I have an old Archer MR200 (Orange branded Flybox) that has wan port and a LTE wan port. It is this: https://openwrt.org/toh/tp-link/archer_mr200

I thought I could plug this into one of my Uni EdgeRouter ER-X on eth3, and trunk one of the vlans down it, and also have it configured to failover to the LTE device if access to the Internet went down on the Ubi ER-X.

ER-X
I put a pvid of 100 on the switch0 eth3.

Archer MR200
I installed openwrt 23.
Copied the configuration from the TP-Link RE650 onto the MR200 which contained:

/etc/config/network:   Changed the router IP address on the default vlan 100 
/etc/config/dhcp:      Disabled DHCP because the ER-X will  manage this.
/etc/config/wireless:  Changed the names of SSID so it would not clash with the overlapping SSID from the TPLink RE650, but kept the *option path* from the MR200.

All sounds good, except I realised that of course the wan on the MR200 is set to the LTE device, and the rj45 port4 on the back the the router, that is labeled lan4/wan, is not configured as a wan port.
Even so, I plugged it into the ER-X eth3, and a few mins later the networks started hanging :slight_smile: I unplugged the MR200 and the network unhung themselves, and came back from the dead.

  • I have got some questions

How should I configure the lan4 set-up as the default wan port?
How can I get the LTE wan port to be configured, but not in use?
What small pkg should I configure to do a fail-over between the two wan devices? I read mwan3 might help in this case.

Here is the config in case it helps?

  • /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxx:xxxx:xxxx::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config bridge-vlan
        option device 'br-lan'
        option vlan '100'
        list ports 'lan:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '200'
        list ports 'lan:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '300'
        list ports 'lan:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '400'
        list ports 'lan:t'

config interface 'lan'
        option device 'br-lan.100'
        option proto 'static'
        option ipaddr '10.210.10.4'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'vlan200'
        option device 'br-lan.200'
        option proto 'none'

config interface 'vlan300'
        option device 'br-lan.300'
        option proto 'none'

config interface 'vlan400'
        option device 'br-lan.400'
        option proto 'none'
  • /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '140'
        option band '5g'
        option htmode 'VHT80'
        option country 'PA'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '50'
        option encryption 'psk2+ccmp'
        option key 'xxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '9'
        option band '2g'
        option htmode 'HT40'
        option country 'PA'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '24'
        option encryption 'psk2+ccmp'
        option key 'xxx'
  • /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

To do what you want, you really should have the main router -- the ER-X -- do the failover routing. I don't know how to do it on EdgeOS, but I'm pretty certain it can be done. This is a question for the UI forums.

From there, you'll setup one of the ethernet ports on the ER-X as an additional wan, and the MR200 will act only in the capacity of an LTE modem. It will be the responsiblity of the ER-X to manage all the routing and to prevent data use except in failover contexts (there will almost certainly be some data use to maintain the connection as a means of verifying the LTE wan is functional, but that should be minimal).

I wouldn't use the MR200 for anything else, though, as it is quite limited (old/slow processor, only 100Mbps ethernet ports, and much slower wifi than your RE650).

Hi again!

Your idea is a good idea, but unfortunately will not fit in my scenario:-

The RE650 is on the top of the house, and does not provide good wireless 4 floors down. Think tall and narrow townhouse.

Also, I do not want clients on that RE650, or the ER-X, to have access to the LTE connection.

I will only provision a max of 90 Mbits down here on the ground and basement floors so the 100baseT ports on the Archer MR200 are adequate for me.

Your idea means I have to buy 1 x LTE router, and 1 x RE650.

My idea means I reuse my MR200 and do not have to spend more money.