Archer D7 support

I have tested the prebuild image at my device, the prebuild image for the D7b is working

I have some suggestions:

As long the internal DSL modem is not usable, the is no need for the "ppp" related packages in the image and also the WAN connection should be linked to the Lan4/WAN port in DHCP/DHCPv6 Mode. I have done in my build for the 18.02.
I have no DSL, but a fibre media converter for internet access. This device would be connected via the WAN/LAN4 port.

Thanks for your work :slight_smile:

1 Like

While (probably) true for your specific use case, anyone who wants to use their Archer D7 (with an external/ dedicated) modem on an ADSL/ VDSL line will still need PPPoE.

The term "fibre media converter" however rings several alarm bells, as this usually implies WAN throughputs up to and exceeding 1 GBit/s line speed, something no ath79/ ar71xx device, such as your archer d7, can deliver - it caps out around roughly 150 MBit/s, 200 MBit/s if you push it (ignoring lags).

@slh I only use the D7b as a wlan access point, my booked internet line speed is 200/100 MBit/s at the moment, without the hardware nat support near the limit of the device. Inhouse I was able to measure speeds up 200 MBit/s via 5 GHz WLAN via the D7b ( Notebook <- D7b -> 1 GBit/s Link -> Backbone ) with ipref3.
It´s right the special needs of external DSL was out of my view, the Linespeed of DSL now also reach up to 250 MBit/s

1 Like

The ppp packages are from the default openwrt configuration, I didn't add it. In my build I added only LUCI and nano.
For what concern the "Lan 4" as a WAN port in DHCP client mode, it should be already present in my build (and in the commit).
Actually, in the commit and in my build I put in the same vlan the internal port connected to the DSL modem and the "Lan 4". I did a quick test few days ago and seemed to be working without problems...

1 Like

Hi @numero53 could you please tell me how I can install OpenWrt on Archer D50? I ordered one on Ebay for around 11€. They are a secret hint to be honest if OpenWrt will work on it. I just used it with OEM als a WDS-Repeater and were able to transfer about 14 MByte/s to a local NAS, but still having trouble to access the internet proper even when my clients were configured with correct ip, gateway and DNS. So I just wanted to use the D50 as an AP. In my FritzBox 7490 it was connected with 866 Mbit/s. So that's why I switched from wired to wireless. Through WAN or LAN Ports I unfortunately just reach 3 - 4 MByte/s from my internal NAS via FTP or SAMBA, I don't know why exaktly this is a problem but has something to do with the Fact that my NAS has 1 GBE Interface and if you switch somewhere in between to 100 Mbit/s FastEthernet it drops down to that Datarate of maximum 3 to 4 MByte/s. That also happens with other OpenWRT devices. Just one other device (Tenda F1201) did even with Fast-Ethernet-Switch reach the 100MBit/s on my Laptop. - The performance issue happens with Windows and Ubuntu via Ethernet-Connection and also with wireless. - Also Performance of wireless under Ubuntu or Linux in gernal sucks for AC-Wifi somehow.

But back to my orginal question: Could you please provide how to switch from OEM to OpenWRT Firmware? - I noticed that there is already a support page in OpenWRT-Wiki but no special instruction. - I guess we could manage it via TFTP flash through the known IPs and but not sure. So I wanted to know and also I am sure we have to strip somehow the bootloader off before flashing an image.

So it would be great to bring this device with proper Atheros-Chipsets to fly!

Hi @suppenkasper0815,
The Archer D50 is a very cheap device nowdays... good choice!
In the commit message I wrote all the instruction needed for a clean OpenWrt install using a USB-UART adapter.
You should open the device and follow the "Flash instruction under U-Boot, using UART" section.
However this is not the right thread... If you have other question about the Archer D50 you should create a new thread :wink:

1 Like

Thank you very much!

Is it maybe possible to split or cut my and relevant posts for Archer D50 into a new thread by an admin?

Is there no way without opening the device? I guess it's as hard as the opening mentioned of Archer D7. I also guess the pining is at the same place and you also need to connect the RX Pin by cable like on D7. Am I right? :wink:

Have you already performance experiences with both devices?

Your instructions are pretty clear so far I can say atm.

By the way, I also saw Archer D7 under 20€ at the same shop I'm eBay. - So if the performance is equal to Archer C7 this should be the choice for future devices...

Thank you very much already for your great job you've done so far!

Hey @numero53 ,

I have no 3 devices. One D50, One D7 and one D7b, so I can test every image and scenario. - The major problem at the Moment is now already the case-opening...

Could you please give some hints or pictures? I found the 2 screws under the information plate, but haven't found how to reject the clip on the upper side and the side clips.

Would love to get some hints before the case is broken...

Thanks guys

Hi guys,

I managed to use the initram build of @numero53

A great work! Just noticed it's not possible to use wwan 5GHz and AP mode at the same time. That's a pity and worked with the good old 4/32 tplink 841 and Co devices...

Maybe there will be a possibility, because in OEM it was also possible to use WDS to login my wifi and use the 5GHz at the same time as AP.

But anyway, I'm not sure what is the correct position to write it into flash because there a several addresses. I read an adress 0x80800000 and the one from I booted 0x81000000.

This is my D7, but I also get soon a D7b and would love to get some hints. - I can also try out things because they are just gadgets for me if you wanna have something tested...

Actually the throughput was better than with WDS Mode in OEM. In OEM max was 130 Mbit/s and with the openwrt it's usually around 200 Mbit/s.

1 Like

Hi guys
I was following your efforts for about a week or so and decided to give your work a try on my device.
I got an archer D7 v1.1
The firmware on it was unfortunately quite recent.
I have the strange issue that pressing "any key" which apparently equates to the letter "t" does not work on UART to interrupt the normal boot sequence.
I've tried all kinds of keys and also another USB-UART adapter, and also quadrouple-checked that I'm on the correct pins and voltages.

Is there something special to it that I'm missing out?
Default settings for screen with 115200 bauds should work right?

Yeah opening that thing isn’t the easiest thing but I postet some hints a while ago at

Hi everybody. Thank you for your nice work. I have Archer D7 and managed to open the box. I don't have any usb uart adapter I was wondering if it's possible to use raspberry pi gpio to connect to router. Also what is the correct voltage. I know rpi gpio is 3.3 volt. Do I need a level shifter to connect to Arher D7?

Hi, I have a question. In the port.serial section of website it is written that vcc should not be connected but in your image if I understand correctly rx, gnd and vcc are connected and tx is not connected. Is this the correct way to connect?


if you want to use the serial connection to normal way the rx, TX and GND has to be connect. The logical level is 3.3 Volts.


Thank you very much I'll try to install it with Rpi and share the result here later.

I finally managed to get the serial connection. There is one problem the environment I get after serial connection seems to be cfe. Not u-boot. Any suggestions?

There are two complete CPU groups inside the D7, a Qualcomm controlling the main routing functions and a Broadcom as the DSL modem. CFE is generally associated with Broadcom. Find the other serial port that is connected to the Qualcomm CPU.

Thank you very much. Now I have another problem. I opened the case so looking at the board from left to right we have vcc, gnd, rx, tx. If I connect the wires using this layout it doesn't work. It work properly for Broadcom part though.


Finally I could connect to Qualcomm but there is strange problem. Unlike Broadcom which shows CFE bootloader and boots normally, the u-boot stops after two lines. This is what I get and after this it just stops working.

U-Boot 1.1.4 (Jan 21 2016 - 16:02:58)

ap135 - Scorpion 1.0

I also checked both router mode and ADSL modem mode work perfectly under TP-link firmware. Any ideas how to solve this?

The Vcc and GND pins are usually easy to tell because they connect to larger areas of copper than the Tx and Rx. Positively identify GND and Vcc and double check with an ohm meter if necessary. The GND will be zero ohms to other grounded parts like the antenna cable shields. The Vcc will have very low resistance to the inductor in the 3.3 volt regulator. Ohmmeter tests are always done with the power to the unit disconnected.

Once you have those positively identified, put your serial converter ground on GND and leave it, and leave Vcc alone.

This leaves Tx and Rx which will have small copper traces to the CPU. It is OK to try connecting Tx and RX both ways to the serial converter. It will only work one way. TX from the router needs to cross over to Rx on the converter and vise versa. If you don't get any data swap the two wires.


Probably the problem is caused by the adapter. I tried many USB-SERIAL adapters and many of them shown similar behaviour. The adapters based on the CP2102 work better for me.
However if you connect the adapter after the start of the bootloader (1 or 2 seconds after you switch the router on) you should be able to bypass the problem :wink: Once the serial connection works properly you can soft reboot the router and you will be able to stop the boot