Archer D50 Support

excuse me for my ignorance, can this be flashed using the oem gui :


would it "brick" the D50 router ?

Hi gfanini,

actually I can't really tell you, but I guess the OEM refuses the firmware and I haven't tried if the device supports tftpd boot service for flashing using tftp protocol... Maybe you can try listening via Wireshark to the usual addresses in the range Usually the listening address is or

Otherwise you need to open the case and solder some pins like I did to the qca chipset and stop the boot process by pressing tpl during the auto boot sequence.

indeed it would not accept it "error code 4503"
would it be a lot of trouble for you to compile a "factory" version that is uploadable from oem gui ?
with wireshark I can't see any evidence of any tftp request from the router, pressing reset or not

I'm sorry, I am not able to compile that. But it's not very difficult to open the case. There are 6 clips around the lid and you can push a flat small screw driver inside the brackets during pulling the lid then it opens quite easily. It's way easier than the D7.

But first you need to unscrew two screws under the label in the right and left corner of it.

Then it's easy to solder 3 pins in the qca area or just take a telephone twisted pair piece and cut it as pin. That's how I use it.

Have fun with the gadget work and don't give up.

how can I fetch the correct archer D50 source (on linux ubuntu) :slight_smile:
I tried doing:
git clone
cd openwrt
git checkout v18.06.1 <<<--------- which version is it
./scripts/feeds update -a
./scripts/feeds install -a

but I am lacking the /target/linux/ath79 folder it seems I did something wrong it seems to fetch it from git from root user but not as normal user
git fetch gives openwrt-19.07

Subtarget (Devices with small flash)
Target Profile (Archer D50) only with subtarget generic ?

there are errors but it builds the bin/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-d50-v1-squashfs-sysupgrade.bin

I wonder if the full factory.bin could be enabled

Hey @gfanini it's great that you wanna compile an own version, maybe you can share the results and please build in wireguard with luci app.

There are also standard images in the official repository for D50 already since I think 18.06.2

Your try with 18.06.1 is maybe to old.

The newest version is 19.07.3 in that version there should be ath79 un the older version you need to use I think ath9k, but maybe there are better experts than me for that question...

Maybe try also the newest 20.x version available for that device if you compile from scratch...

Hi @gfanini,
I am answering here your email also. :slight_smile:
Currently is not possible to flash the OpenWrt image from stock gui because of the missing private key. You can read more here:
"The TP-Link private key is still required to create images which are accepted by the stock firmware update routine"
For what concern the WDS capability, I don't see any limitation.. however I'll test it :wink:

hmm so there are issues of which branch to use ? 18.06.2 say would compile the "factory" but there is an issue with private key ...
the ath79 target seems present since release 19.07.0
so perhaps with that version no compile errors

Is it possible to upload the sysupdate either with tftp or usb ?
I tried to press reset pin and also the WPS button turning on but no sign of tftp requests from the router with wireshark on ethernet cable ...

the reason I was looking into open wrt was that I could not find on the stock tp-link firmware the option wireless advanced WDS repeater function, it works both 2.4 GHz and 5 GHz if anyone is reading like me unaware ...

I don't remember when the D50 was added, however I advice you to use the 19.07 target (here).
Unfortunately, to flash it there is only one way: disassemble the router and then use the UART interface to send the openwrt firmware.
I am sorry, but no one managed to flash it without opening the case :frowning:

Sat, 18 May 2019 17:59:49

1 Like

Hey guys, I wanna use your attention and wanna know your opinion about the sfe of @gwlim. He developed a significant fast algorithm implementation. I posted in the D7 thread already my experiences with transforming the the D7 into C7 and using the great images of him.

Is it possible to implement it for other devices like our D50 and others? Maybe through a package installation? It's much faster and more effective than nft-offloading.

Any further ideas to pull down the power consumption of our D50 and D7 devices with removing power delivery for modem part?

Hi guys!
I've made a mess with my archer D50, to install openwrt I flashed his NOR with a soic8 clip, but now it doesn't boot :face_with_head_bandage: When I turn on, it remains with some leds lit and nothing more :woozy_face:

I already tried to reflash the NOR with the original firmware I previously extracted but none happens, probably I've red it with some errors.

Could anyone help me to resuscitate it? I need the bootloader or the full firmware (bootloader + openwrt)...

Hi @Lorix

I added all of my partitions of D50 to here:

@gwlim maybe I can test an sfe image for that great device D50 if you help me to compile an image.

@numero53 Have you found where we could maybe adapt die MAC-Adress with Hexeditor in boot partition?

1 Like

Thank you suppenkasper0815!
In the next days I'll try to reflash it :slightly_smiling_face:

1 Like

If anyone is able for a deep dive to the project SFE of gwlim I would really appreciate an implementation for our D50 device. Unfortunately I'm not to much of a programmer to be able to create an image with active sfe. of gwlim

1 Like

Hi, im trying to flash d50 from uart but i get strange symbols, and after some second normal booting information. i can stop the boot but with strange symbols is impossible to configure. can someone please help me, thanks

Hi, please recheck your clean soldering points and safe contacts to your ttl adapter (pl2303 or cp2102) work both fine for me. Use 115200 and if you still get only strange symbols Chechnya ground signals (gnd) and try switching rx/tx signals. , I uploaded a video to show the problem. it is strange becouse it starts with wrong symbols and then it continues ok.

can someone send me a full dump with openwrt? thanks

@niknintendo look at my posts above. I added everything already.

BTW were you able to stop autoboot by pressing "tpl" during autoboot pause?

I think your connections are not good soldered. You should use smaller wires and push them through the wholes... But be careful not to unwrap the soldering points from pcb