Archer C7v2 bricked, no Serial?

Hey guys, a friend of mine bricked his Archer switching from ddwrt to OpenWrt.

  • Rooter booting up, LAN/WAN IPs blinking if connected, no wireless, no webinterface.
  • Pressing WPS does nothing, no connection to TFTP Server.
  • no bootloop

Im trying to get a serial connection using a FTDI 232, RX/TX/GND connected. Tried 800Ohm pullup and changing tx/rx, however, i get no output at all in picocom (115200 baud)
Any Idea what i might be doing wrong or what i could try?

@janmaier27, welcomne to the community!

Did you also connect a 5 Volt to 3 Volt TTL serial converter?

My RS232 has a built in switch and i double checked with an osci that it is indeed putting out 3.3V/5V depending on the dip switch.
Not sure wether its RX can deal with 3.3V though, but i previously used it on other devices that also communicate with 3.3V serial and it worked flawless.
I think i fried my bootloader because i neither get any serial output nor any request on my tftp. The whole router is completly unresponsive and only acts as a switch.

You are just not seeing an attempt to connect at the server itself, or you have sniffed the wire to see if there is an attempt.

I checked network traffic with wireshark, however, that only sniffs packages addressed to me, correct? Is it worth it to attempt something else?
From neither getting serial, nor request or packages on 192.168.0/1.66 i figured it wouldnt be worth to investigate into that further.
The initial reason i tried serial connection was in order to check wether the router is trying tftp at all.

Its "first" step in trying to connect to anything would be an ARP request, which is an Ethernet broadcast, not an IP-addressed packet. The MAC under U-Boot may be completely different than it during kernel-based operation.

Ill take another look into that, but as far as im concerned i woudve seen that in Wireshark last time already. Thanks anyway, ill report back!