Archer C7 Wifi Turned Itself Off?

Hi there,

Why would an Archer C7 V2 wifi turn itself off?

I've had OpenWrt 22.03.4 running fine on it for about 4 months or so.

It happened last week for the first time (that I've noticed).

Should I be suspicious or is this a fairly normal thing?

Not enough info to know at this point...

It is not 'normal', but might be expected if you're using DFS channels (on the 5GHz band). The 2.4G band shouldn't be affected here, but it's not clear if you had that enabled or not.

You config files will be helpful in understanding this...

There are basically two very distinct potential causes:

  • if you are using a 5 GHz DFS channel, the router might have to switch the 5 GHz radio off, if it encounters an active radar in your environment.
    This would be a legal (regulatory) requirement, not a bug.
    At least for testing, it does make sense to configure a non-DFS channel to rule this out.
  • it is possible that the proprietary firmware running on the wireless chip itself (ath10k-firmware-qca988x-ct or ath10k-firmware-qca988x) crashes and doesn't manage to restart.
    This would be a bug, but due to the proprietary nature of this firmware doesn't provide much of a grasp for debugging (you should see notices in dmesg/ logread though), other than trying the relative other option.
2 Likes

Thanks for the replies.

I only meant normal, I guess, in the context that some people reported this happening in this thread, so I wasn't sure if it is to be randomly expected on a C7 or not, etc.

I'm not sure what DFS channels are.
And how do I find my config files again? I can ssh in, I just forget where they are.

Not sure about radar around here, but I suppose it's possible. Like military radar or am I just being a newb and you mean something else related to wifi?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

The wikipedia article is pretty good. Possibly military, but very much more likely to be local weather radar.

Interesting, thank you.

Ok, thanks. Here's the requested info.

Also, I am using the BanIP package, as well as a Raspberry Pi on *.105 that serves as DNS (running Unbound, and PiHole). I think it's all configured correctly, but I could always use any advice.

# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option delegate '0'
	option ipv6 '0'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'
	option peerdns '0'
	option ipv6 '0'
	list dns '192.168.1.105'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'







# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'CA'
	option channel '153'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key '*******'
	option ssid '*******'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option band '2g'
	option htmode 'HT40'
	option channel 'auto'
	option cell_density '0'
	option country 'CA'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '*******'
	option encryption 'psk2+ccmp'
	option key '*******'







# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option sequential_ip '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option dhcpv4 'server'
	list dhcp_option '6,192.168.1.105'
	option leasetime '720h'
	option ra_default '1'
	option dhcpv6 'disabled'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option name '*******'
	option ip '192.168.1.105'
	option mac '*******'







# cat /etc/config/firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'
	option flow_offloading '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

Do you think my config files look okay, by the way?

Hi @psherman , I uploaded my config files like you asked. Any ideas as to how they might have contributed to my wifi turning itself off?
Thanks.

Based on the config you shared, channel 153 @ 80MHz in Canada is not a DFS channel, so my original guess was wrong.

The next question is this: was ethernet working properly? And if so, was there anything in the log to suggest why the wifi went down?

Thanks, Peter. Ethernet was fine, I connected that way to fix the problem.
I didn't check the logs after that happened. Which log files should I check? Do you think any info would still be in a log file?

Given the time that has elapsed, it is likely that nothing would be in the log anymore.

If it happens again, immediately use ethernet to login to the router via ssh and then grab the output of

logread

Ok, will do. Thanks again, Peter, I appreciate it.