ARCHER C7 v5 (US) Support

Hi brothers ! i sell the old tplink 842nd ver1.1 and i buy these router ! look amazing speed on 5GHZ, but i did find support for openwrt. the version is v5.0 (US) the firmware files has 16mb. could you someone help me to install openwrt to these router ? thnk you!

I don't see it on the OpenWRT pages yet, but it does look to be up at https://wikidevi.com/wiki/TP-LINK_Archer_C7_v5.x

CPU1: Qualcomm Atheros QCA9563 (750 MHz)
FLA1: 16 MiB (GigaDevice GD25Q128CSIG)
RAM1: 128 MiB (ESMT M14D1G1664A-2.5B)

WI1 chip1: Qualcomm Atheros QCA9563
WI2 chip1: Qualcomm Atheros QCA9880-BR4A

ETH chip1: Qualcomm Atheros QCA9563
Switch: Qualcomm Atheros QCA8337N

thank you jeff, not even on snapshot, i tink maybe other version firmware was compatible.

no one ? has the same router or flash the v5 ??????????????????????

There is a pull request still pending for Archer C7 v5 support.
You can compile an image yourself and test it.

1 Like

thank you for your reply !

i got WORKING LEDE ON ARCHER V5

1 Like

only toruble i cannot install mwan3 got the next error:

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-mwan3:
 * 	kernel (= 4.9.105-1-74b9e4f13d0eb32a5f2269b23d9bffc9) * 	kernel (= 4.9.105-1-74b9e4f13d0eb32a5f2269b23d9bffc9) * 	kernel (= 4.9.105-1-74b9e4f13d0eb32a5f2269b23d9bffc9) * 	kernel (= 4.9.105-1-74b9e4f13d0eb32a5f2269b23d9bffc9) * 
 * opkg_install_cmd: Cannot install package luci-app-mwan3.

I tried loading 18.06.1 version of OpenWRT onto my new Archer C7 v5 via TFTP. I saw the file was requested by the router but it never actually got flashed to it. Has anyone else gotten this to work?

The problem is the firmware upgrade routine says "invalid file type" after file selected. Has anyone overcome this?

https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c7_v5 , i have openwrt running succesfully