Archer c7 v5 (new one) installing OpenWrt process

After i bricked my 1st Archer C7 v5 DDWRT trying to revert factory firmware to install OpenWRT, i am a bit afraid. I Got a new one, and it is still on factory firmware, didn't upgraded it to anything yet not even latest TP-Link firmware.
I read on the wiki, OpenWRT installation on Archer C7 V5 must be done with tftp :
1: / is there any bricking risk with tftp ? or may be there is a sort of safety which prevent any wrong firmware to be uploaded ?

2:/ Supposing everything went well, what should i expect when i will log on OpenWRT on the Archer C7 v5, a telnet/ssh interface or similar to DDWRT/TP-Link web interface ?

Thanks for your understanding, i really don't need another brick, my router budget have been blowed for years this week.

1 Like

We sort of remove that safety when we flash the openwrt factory bin, which modifies the header slightly so that it can accept future openwrt firmware flashes.

How long did you use the archer c7 till it got bricked?

You'll get a luci web interface on or sure) if you flashed the release version; and you will only have ssh access when you flash a snapshot build.

Like I already said in the other post, the revert to factory firmware instructions are outdated in the wiki(those aren't for v5 version, rather those are for the v2). See this comment that I linked below for more details.

1 Like

Thank you for your answer.

Two weeks, i used my 1st Archer C7 v5 during two weeks before bricking it (may be less).

My intention in the beginning was to try both open firmwares (DDWRT + OpenWRT) and eventually keep the one which would be the best to my use (i came from Tomato during several years and loved it - so i would have kept the firmware who would be the closest to Tomato - in term of possibilities, interface, etc).
After i installed DDWRT, i 'played' a bit with it and very quickly i wanted to try and see OpenWRT. Sadly, it was not possible to switch directly from DDWRT to OpenWRT, so i tried to revert to factory firmware, it never worked...

This led me to do things really stupid to try to revert the Archer C7 v5 to factory to install OpenWRT.
Firstly i tried to webupgrade to the oldest factory firmware Archer_C7_V5_190726.bin, never worked, then I tried several tftp firmwares on PC and MAC,on PC it never worked completely (i always got a ack error during transfer - i still have the log) and on Mac with PumpKin the .bin were sent each time, but after the router restart, it was always on DDWRT.

I can't count the number of times i was following a tutorial, or a guide thinking it was for C7 v5 and it was for the v2 v4 or even Archer A7, it is really easy to make a mistake router reference are really close and not every doc/guide/videos are showing the router revision.

Anyway, hopefully the Archer C7 V5 is not too expensive, and i got another one ...

And By the way, i saw two different way to install OpenWRT, the 1st from TFTP, and the other from Webupgrade, are both working (I prefer Webupgrade, tftp scare me)?