Archer C7 v5 DDWRT prefer to have OpenWrt on it - can't install

My Archer C7 v5 asked me today to install OpenWRT, as a good boy, i obeyed, but it seem DDWRT don't want to let me install anything else on the Archer...
I followed the steps from the wiki, and tried to install original TP-Link Archer C7 v5 firmware -> didn't worked, tried ArcherC7v2_webrevert.bin didn't worked too, tried also openwrt-19.07.4-ath79-generic-tplink_archer-c7-v5-squashfs-factory.bin didn't worked...
It look like if DDWRT don't want us to install anything else...
Any help please ?
I am terminal friendly so i can try telnet cmds, or ssh, if i am sure they will not brick the router...


PS : i tried very long ago DDWRT and Openwrt on a WRT54GL, but i can't remember so much troubles to switch from DDWRT to OpenWRT, If I recall correctly, the switch between the two firmwares was easy, no need to flash a special revert firmware..

This model is quite commonly used with OpenWrt. There is documentation here:

It is best to start from stock firmware. Follow dd-wrt directions to return to stock, if there are any.
The other method is TFTP recovery. That will work no matter what firmware is presently installed.
1 Like

i followed ddwrt instructions to return to stock firmware, but it didn't worked, each time the router reboot after upgrade, it is on ddwrt... uhu stick you know it ? it is ddwrt... i will try with tftp if it don't work.

Topic/link: Archer C7 v5 Wi-Fi Problems & Revert to stock help

“i followed ddwrt instructions...”. Follow Openwrt instructions per previous reply...

If you use TFTP you shouldn't have to revert to stock before installing OpenWRT,
just grab the proper squashfs-factory, rename it to ArcherC7v5_tp_recovery.bin, and do the
TFTP sequence, as described in the link in the 2nd post.

Even if your TFTP fails, you should at least see the router requesting a FW file in the
TFTP log. If there's no request over TFTP, then you're doing something wrong, like forgot to
change the IP, disable firewall, etc.

Here's an excellent TFTP server for Win -
FYI, some browsers flag this site as dangerous, I really have no idea why.

1 Like

Site is marked as dangerous because it's served from HTTP and link to executables.

Yeah, that would explain it.

I tried this night with TFTP 4.52 32bits, but there is something weird.
As explained in the guide, I :

  • DIsabled firewall on computer hosting tftp. and set network settings to
  • Powered off the Archer C7 v5
  • Pressed Reset while i was powering the router, and i kept pressed reset until tftp start its transfer.
  • TFTP started the transfer, and continued while the router seem to continue to boot ???? - i saw the leds lighting one after the other like during normal boot), and of course after i rebooted the router i found DDWRT v3.0 still installed on it...

I wonder if i didn't kept reset button pressed for too long..

What should happen when the router enter recovery mode ? Is he supposed waiting 30 seconds before rebooting or continuing boot ? or should the router stay in recovery mode until we reboot it ?

I think the first thing you have to make sure is that the router is in recovery mode. Follow this guide:

Then make sure you have a valid connection between your computer and router, ping it.

I found tftp32 not very helpful. I used this tool ( to upload the new firmware via commandline (TFTP -i routeradress PUT firmwarefile.img).

1 Like

In fact wasn't putting the router in recovery mode, by pressing reset for too long, i was starting recovery (tftp was starting transfer) + resetting router+ rebooting router this in loop at least two times (i have read somewhere i had to push reset for 50 seconds).
When i understood this, it was better.
Suffice to say Press reset button until tftp start transferring or if tftp is not connected, until the two arrows led are lighted.
I tried with tftp old version 32 bit, and newer version, didn't worked file transferred but probably with an error :



Connection received from on port 2148 [14/11 10:38:09.113]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [14/11 10:38:09.113]
OACK: <timeout=5,blksize=1468,> [14/11 10:38:09.113]
Using local port 63161 [14/11 10:38:09.113]
TIMEOUT waiting for Ack block #7014  [14/11 10:38:43.801]

I tried on Mac with a very nice little software perfectly (seem perfectly) compatible named Pumpkin :
It worked, i compared the size of the flash file (in bytes) to the transfer, and they were the same...
Sadly each time after the tftp "flash" router rebooted another time on DDWRT (same version i had)./

Edit : I tried both, old TP-link Archer c7 v5 firmware renamed, and Openwrt squash factory renamed (a 4.5Mo file). Same Problem. I don't understand why it is so complicated to switch from DDWRT, when it was for my old WRT54GL, i didn't got so much troubles, switching from DDWRT to OpenWRT was easy and didn't needed a special revert firmware.

When the router TFTP transfers the firmware but refuses to flash it, it is usually a mismatch of the country codes in the firmware header vs. the country compiled into the bootloader. I think the Russia (RU) version of the router especially has that problem.

1 Like

I think i downloaded it from US server or may be FR, and I got the router in Morocco (.ME area)... I will try with local firmware.

Edit : OMG on the local website, they have only Archer c7 v3 firmware :frowning:

The country / region code should be on the label on the bottom with the model number, e.g. "Archer C7(EU)".

1 Like

Right, it is an EU, and after i saw your message,i tried with both, EU and US firmwares...
I watched a Youtube video, very long, but very interesting :
The person which upgrade his router do it completely with MacOS terminal, with SSH, in fact as far as I understand, he send it in the /tmp folder, then he modify the firmware with a single mdt utils command ... I have read somewhere to be bootable (flashable) when DDRWT is installed, factory firmware must be modified (header may be ?) It is chinese for me, but what i saw in the video i can do it, it will be probably easier than running tftp on an windows emulation (i am on Mac).
I will try this...