Archer C7 v2 WAN port not getting DHCP

Hello everyone,

I’m having trouble getting my Archer C7 (OpenWrt 23.05.5 and 22.03.7, mips_24kc) to receive a DHCP lease on its WAN port. Here’s what I’ve tried so far:

  1. Directly from a Modem: Plugged the Archer C7 WAN into my modem. No IP address obtained.
  2. Via Another Router: Put a second router between the modem and the Archer C7 (so Archer’s WAN → second router’s LAN). Still no IP address on the Archer.
  3. From a Laptop: Finally, I connected my laptop (running Ubuntu ICS) directly to the Archer’s WAN. The laptop sees DHCP Discover from the Archer and sends an Offer, but the Archer doesn’t appear to receive it.

Hardware / Firmware

  • Router Model: TP-Link Archer C7
  • OpenWrt Version: 22.03.7 and 23.05.5
  • Architecture: mips_24kc
  • Laptop OS: Ubuntu (using NetworkManager “Shared to other computers” / ICS)

Observations & Logs

  1. Archer’s WAN is configured for DHCP.
  2. I ran tcpdump -i eth0.2 port 67 or 68 on the Archer, and I see only DHCP Discover from the Archer, no DHCPOFFER incoming.
  3. Laptop’s tcpdump sees the router’s Discover and sends an Offer back, but it never shows up on the Archer side.
  4. The same issue occurs whether I connect the Archer’s WAN directly to my modem, or to another router, or to my laptop.
  5. The Archer’s switch config says VLAN 2 is untagged on port 1 (the physical WAN jack) and tagged on CPU port 6. And port 6 maps to eth0. Although I switched between eth0.2 and eth1.2 for WAN with no success.
    When used eth1.2. the laptop did not received any DHCP requests.

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd7d:f5c0:15be::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'
	option hostname '*'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'

Other Attempts

  • Swapped Ethernet cables and confirmed link lights.
  • Power-cycled modem and the other router.
  • Verified there’s no IP conflict (e.g., Archer LAN is 192.168.1.x, upstream uses 192.168.0.x or 10.42.x.x).

Any suggestions on what else to check? Thanks in advance for the help!

Power off providers equipment, start openwrt and hook logread -f in putty session, then power on providers equipment.

Typically they do not allow changing MAC without call/week delay on live connection.
Can help if you transfer MAC address from previous router connected.

run tcpdump -i eth0.2 on the archer, if you can get it installed. Otherwise consider the age of the device.

I think it is eth1.2

Thanks, MAC lock would explain why it does not work with the modem (I tried this one tbh.)
But would it explain why it does not get an IP when the laptop acts as a DHCP server?

Does the wan port light up when connected?

Thanks for answering.
It does send the DHCP request:

root@OpenWrt:~# tcpdump -i eth0.2 -vvn port 67 or port 68
tcpdump: listening on eth0.2, link-type EN10MB (Ethernet), capture size 262144 bytes
23:06:04.980740 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from 18:d6:c7:90:cd:11, length 300, xid 0x7e057d05, secs 1075, Flags [none] (0x0000)
	  Client-Ethernet-Address 18:d6:c7:90:cd:11
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 8: 
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
	      Domain-Name, BR, NTP, Classless-Static-Route
	    Vendor-Class Option 60, length 12: "udhcp 1.35.0"

The laptop receives it and answers with an OFFER:

14:58:00.097161 IP 10.42.0.1.67 > 10.42.0.233.68: BOOTP/DHCP, Reply, length 300
14:58:03.099627 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 18:d6:c7:90:cd:11, length 300
14:58:03.100098 IP 10.42.0.1.67 > 10.42.0.233.68: BOOTP/DHCP, Reply, length 300
14:58:06.102919 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 18:d6:c7:90:cd:11, length 300
14:58:06.103505 IP 10.42.0.1.67 > 10.42.0.233.68: BOOTP/DHCP, Reply, length 300

But these OFFERS are not received on the Archer

Yes it does.

Run OpenWrt with default settings. One of the default settings is firewall port 68 UDP open from the wan, which is how DHCP offers are received.

1 Like

It is open, I have tried with defaults as well, no luck

	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

You can re-assign one LAN port as WAN if there is any physical damage.
Luci/Network/switch.

1 Like

As mentioned by @brada4 , you may be dealing with the behavior of the ISP/equipment itself. Specifically, it might not issuing a DHCP lease due to an existing learned MAC.

And as @mk24 said, start with a default configuration of OpenWrt (reset to defaults if you haven't already done so).

Then, follow the directions here:

Does that fix the issues?