Archer C7 v2 stuck on bootloop. Tftp doesn't install the firmware

I am not sure what happened, but here's what I think happened.

I restored a backup configuration, then since it took too long to boot I assumed some anomaly broke my router. Because of this I turned it off and I tried to do tftp by pressing the reset button for as long as possible. When I did this, I think I accidentally made it do an openwrt factory reset instead and cancelled while it was in progress. I believe this was the case because I did see a openwrt wireless signal on my phone, which I found weird. I was also not aware that you can factory reset with that same button.

Tftp seems to work. My computer is set to use the ip while the gateway is, I am using the first lan port. Since tftpd32 shows that my file has been fully downloaded (100% progress) I am sure the connection is not the problem. However my router doesn't react to this, I assume it's rejecting the file.

I had read many posts of people having this issue, however I often end up being lost because these people usually have more expertise than me. There's not many pointers on how to do what they had been asked to do since they already know. Meanwhile, I am completely lost. I struggle to find where to begin.

Here's what my router led patterns look like now:

  1. All lights light up for 3 secs
  2. Power, System, and Wifi 2.5GHz led, the rest go
  3. The rest flash except 5GHz flash once
  4. Ethernet 1 led lights up as usual, very normal
  5. The rest except wifi 5GHz flash for a second
  6. back to 4. (Power, System, Wifi 2.5GHz, Ethernet 1 on)
  7. All lights flash
  8. repeat

Note: All lights are green. WPS never lights up. When I tried to do tftpd, the ethernet 4 led lights up instead of WPS. If I press reset, the pattern is the same.

which image was used ?

if you created a custom image, did you see the waring at ?

I tried the stock firmware images, all versions from the US, and the openwrt image.

is it possible to be less vague, there's only one openwrt image out there, right ?

The ath79 generic openwrt squashfs-factory firmware from the wiki, version 22.03.5 from this page (this download link

and all the stock firmware versions found on this page I tried all of them.

there are three c7 v2 factory images in, you should probably try at least one more.

Based on the u-boot warning, going back to could also work.

1 Like

trying all the images available for my router, on versions 22.03.5 and 22.03.1 didn't seem to work. There's no update to the pattern of the leds. I am not sure if I should give them more time or if there should be any indication that it went through. If it needs more time, I uploaded an initram firmware from 22.03.1, and I haven't interrupted the process in any way. (didn't turn it off)

the initramfs isn't made to be written to flash.

oh, well, it didn't work anyways.

The TFTP firmware must match the country code the router was sold for, this is on the label on the bottom next to the model number. If the code doesn't match, the bootloader will download the firmware but not flash it.

Next step would be to use serial. Serial recovery consists of booting the initramfs from RAM then using the console CLI to install the sysupgrade to flash. It's a reliable process once you have everything set up.

is there a way to do this on an archer c7 without soldering? since it doesn't visibly have a serial port. I am somewhat confused on how people do this, since I see some people mention an usb, and I saw a video of someone using a cable without saying what kind of cable it is. (It connects from the router to the pc)

I don't have a soldering iron.

according to the serial's very easy to locate, but you'll need a USB TTL serial cable, they're a couple $ at Amazon.

another question is obviously, if it's worth it ?
add $15 or $20 (to the $5 for the USB TTL), and you'll probably find a better used router.

yeah that's what I was thinking. The knowledge is invaluable so I'll definetely do this some day. It would be 10 dollars for the soldering iron on amazon, and 5 for the usb ttl, a total of 15. I don't think I'll find a better used router at 15, only at 30 I think

I can spend 15. Is there something else I missed? What's the connector called? The thing you have to solder into the motherboard

Remove the cover (obviously the warranty no longer applies) to see if the serial pins are already there. It may have been made before they started leaving them out at the factory.

after opening the router, I saw that I don't have any serial pins. I see that I have 3 cables soldered into bronze colored things, and 3 connected to the antenna ports. I am not able to access the back of this board, since lifting it up is prevented by the cables. I had been struggling to find a place to buy the pins, I keep getting shown the cables, I don't know if I need to buy pins designed for serial connections, or if any pin would work.

If I need to desolder the cables, that adds to the cost since I need a desolder wick, and I am afraid I could break them since they are wires. Do I have to desolder the cables? The alternative would be to have someone hold the board for me.

I want to do this, but I'll also have to buy a new router. I have to consider that time is money, routers aren't that expensive, and that compromise of not setting this up isn't worth it. I waited too long to achieve this "perfect personal only for me setup". After I fix this, I'll probably have this router saved as a backup.