Archer C7 V2 overclock clock drift

Not sure what is the default values but you should only try to increase the NINT and not touch anything else

Could it be the AHB frequency setting?

For some reason, I redid the settings and it seems to be working better after a wipe of the config. I have no idea why. Maybe the overclock just isn't as stable on my particular router?

Gwlim, I see in prior posts you seem to have included an overclock patch. Did you ever set up an overclock using a different bootloader? I wonder if this bootloader is squirrely or something and messing with my stability?

The patch was meant for AR7161, it worked for those

Ah ok thanks. I will try my settings and see how I do. Thank you.

Ok, got a question. You did an archer c7 v4 overclock: Overclocking Router Devices

Did you use Breed? In that thread in surrounding posts, @psyborg said Breed is a bad bootloader and induces clock drift? Maybe that's why?

I'm wondering if it's the kernel's clock timing interacting with it?

I compiled from TP-Link GPL sources as breed does not support QCA9563 for that Archer C7v4

Thank you. I still think there is a bug either in Breed, the kernel, the firmware or something. But I set my clocks to just under 1000 (940 or 960) for cpu and it seems to run fine.

Uptime is 15 days and clock is within the minute! And my WiFi has been stable and I can see in Ookla Speedtest that it wants to do over 350 Mbps down when I test. I don’t have the setup for iPerf but if I did I would.

aybe you can try this

Hello, I own a C7 V2 and I run also on 960 mhz, I added a heatsink trough and had a other power adapter that was 2.5A vs 2.0.

iperf3 -s -V -D

Connecting to host 192.168.1.2, port 5201
[  4] local 192.168.1.205 port 55683 connected to 192.168.1.2 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  52.9 MBytes   443 Mbits/sec
[  4]   1.00-2.00   sec  53.1 MBytes   445 Mbits/sec
[  4]   2.00-3.00   sec  53.0 MBytes   444 Mbits/sec
[  4]   3.00-4.00   sec  52.5 MBytes   441 Mbits/sec
[  4]   4.00-5.00   sec  53.1 MBytes   444 Mbits/sec
[  4]   5.00-6.00   sec  52.4 MBytes   441 Mbits/sec
[  4]   6.00-7.00   sec  52.8 MBytes   442 Mbits/sec
[  4]   7.00-8.00   sec  52.5 MBytes   439 Mbits/sec
[  4]   8.00-9.00   sec  51.6 MBytes   434 Mbits/sec
[  4]   9.00-10.01  sec  51.5 MBytes   430 Mbits/sec

Stock:

Connecting to host 192.168.1.2, port 5201
[  4] local 192.168.1.205 port 65501 connected to 192.168.1.2 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  29.9 MBytes   250 Mbits/sec
[  4]   1.00-2.00   sec  28.6 MBytes   240 Mbits/sec
[  4]   2.00-3.00   sec  28.2 MBytes   237 Mbits/sec
[  4]   3.00-4.00   sec  29.6 MBytes   248 Mbits/sec
[  4]   4.00-5.00   sec  29.5 MBytes   247 Mbits/sec
[  4]   5.00-6.00   sec  29.5 MBytes   248 Mbits/sec
[  4]   6.00-7.00   sec  28.8 MBytes   241 Mbits/sec
[  4]   7.00-8.00   sec  29.6 MBytes   249 Mbits/sec
[  4]   8.00-9.01   sec  30.1 MBytes   251 Mbits/sec
[  4]   9.01-10.01  sec  20.9 MBytes   175 Mbits/sec

I'm using the C7 as AP Only :slight_smile:

Not bad throughout. And I may try the uboot. Thanks for the tip.

So far Breed at 960 seems stable. I get better performance and am limited by the WiFi signal at this point so I will leave it

Thank you for the help!

Thats odd to me... I recall getting speeds of 300-350, limited by my 300mbit cable connection, routing WAN - LAN... with a stock v2. Even 260-280mbit thru the wifi...

To messure the real speed I think it's better to connect two clients, on on lan and one on WAN, im not sure if running iperf3 on router could lead to less results.

My lowly tests were done with DSLSpeedtest, no iperf3, nothing running on the router.

Ah ok well, depends on firmware then however 280mb's wifi seems about the max (CPU Limited) i can get, i have 500 mb's isp atm.

I've seen Speedtest hit close to 400 Mb/s to the local to my city and ISP server (Cox), but I have such crappy interference I have to use a DFS channel to use Wi-Fi since no one else uses DFS. I probably could hit higher if I could have more than 23mW of power.

Link seems fine, so seems im limited by the cpu:)

975.0 Mbit/s, 80 MHz, VHT-MCS 7, VHT-NSS 3, Short GI
866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

I'm also on a DFS channel, however I have airport within 10km :slight_smile: but so far last two days have been good,ddddddddd

Edit:

My nvidia Shield is almost getting 360mb's using 5g seems fine for me.

Zombie revive:

As far as I can tell, 980 MHz is the maximum stable frequency.

I tried 1GHz and I got conflicting numbers with iperf on client vs server. Around a ~20Mbps difference. These settings seem to work well:

iperf goes from 434mbps to 559mbps. That's with qca8k instead of ar8129.

Have you tried changing the "RANGE" field value?

I have not.