Archer C7 V2 - OpenWrt 18.06.4 *** Failed to download the package list

I know, I know...another "Failed to download" thread. I've searched in the forum for a while and I'm looking for some assistance.

I'm running the latest OpenWrt firmware on an Archer C7 V2 AC1750 as an access point only. It's connected to an OPNsense 19.7.4 router acting as router/firewall.

When I try to run the command "opkg update" on the command line in OpenWrt, I get the famous "Failed to download" errors:


Failed to establish connection

*** Failed to download the package list from


Failed to establish connection

(snipped so as not to list every URL that had a connection error since every error is the same.)

Collected errors:

(etc. etc.)

I tried using the command "wget" command as someone suggested in another thread:

root@OpenWrt:~# wget

Downloading ''

Failed to establish connection

So, I tried pinging in the command terminal of OpenWrt:

root@OpenWrt:~# ping
ping: bad address ''

However, if I ping the ip address for instead, it connects:

root@OpenWrt:~# ping

PING ( 56 data bytes
64 bytes from seq=0 ttl=45 time=108.480 ms
64 bytes from seq=1 ttl=45 time=108.097 ms
64 bytes from seq=2 ttl=45 time=107.868 ms
64 bytes from seq=3 ttl=45 time=107.909 ms

So, there's something in my setup where my OpenWrt AP is not able to determine the domain but can ping the ip address directly.

Any advice would be greatly appreciated. Thank you in advance.

Set your DNS servers.


Hi @lleachii. Even though OpenWrt is only acting as an AP? (OPNsense is set up with the DNS server. )

In that case then, you need to set your AP with that DNS server.


@lleachii Thank you for your help. I set the DNS server to point to my OPNsense box and I was able to download now.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.