Archer C7 V2 max. LAN speed on 19.07.04

To be fair, ipq806x is much faster than any ath79 released so far - it just isn't fast enough to route at 1 GBit/s linespeed (without NSS assistance).

Ran few tests on the wired connection again. It does peak at 500+ mbps but the final results are still in 300~. I do not think ISP is traffic shaping. When I connect the laptop directly to the cable modem using the same cable, I do get 600+ mpbs speed consistently.

Router CPU idles at 87 <-> 96% before test. It goes down to 38% when peak download speed is showing in the test.

I have a another thread running about 2.4 GHz WiFi dying in Archer C7. While debugging I had noticed that when I was watching a HD steam on TV (wired connection to Ethernet), my WiFi would crawl. I am not sure if this is related. But it looks like the switch cannot handle the speed. I do have two LAN ports assigned to guest and IoT VLANs each.

I will try the fake ISP and iPerf LAN to LAN test through switch soon. Here are the current speed test results.

Through Archer C7
Screen Shot 2020-12-01 at 3.56.20 PM

Direct to the cable modem. Same Ethernet cable.
Screen Shot 2020-12-01 at 4.21.35 PM

So, currently which OpenWrt supported hardware does 1 gbps LAN routing? I spent a lot of time searching for suitable devices in the market. It seems that everybody is using Broadcom chips these days :-1:

Foremost x86_64 does, easily. mvebu does as well, but typically comes with unreliable/ bad wifi (mwlwifi); the RPi4 would cope easily as well.

Looks more like a misconfigured router that uses software bridging between switch ports, rather than hardware switching. Please post the contents of /etc/config/network for me to verify this.

And yes, WiFi is a known CPU eater on this router.

You could try overclocking the archer. I have it clocked at 1 GHz.

mvebu is pretty much the gold standard for Ethernet.

WiFi from what I've heard works fine with the WRT3200ACM and WRT32X. The older models are fairly poor performers. You also need to forgot about WPA3.

Here is the config. BTW I am using another router as AP and 2.4 GHz is turned off all this time due to WiFi issue.

/etc/config# cat network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd00:1234:43bb::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option hostname 'router'
	list dns '9.9.9.9'
	list dns '149.112.112.112'
	option peerdns '0'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	list dns '2620:fe::fe'
	list dns '2620:fe::9'
	option reqprefix 'auto'
	option reqaddress 'try'
	option peerdns '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '3 2 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '6t 1'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '5 0t'

config interface 'guest'
	option proto 'static'
	option ifname 'eth1.3'
	option ipaddr '10.11.3.1'
	option broadcast '10.11.3.255'
	option type 'bridge'
	option netmask '255.255.255.0'

config interface 'iot'
	option proto 'static'
	option ifname 'eth1.4'
	option ipaddr '10.11.4.1'
	option broadcast '10.11.4.255'
	option type 'bridge'
	option netmask '255.255.255.0'
	list dns '9.9.9.9'

The configuration looks simple and correct.

So - obvious question: is the result on speedtest.net (as opposed to dslreports.com) also slow?

My ISP test results match dslr results. Given that the direct modem connection is fast, why do you suspect DSLR results? I even tried fast.com. It show similar difference albeit slightly slower than DSLR.

1 Like

OK, so we know that the CPU is not the bottleneck. Could you please do the test with TTL adjustment on the router, to rule out ISP cheating? Here is how:

opkg update
opkg install iptables-mod-ipopt
iptables -t mangle -F POSTROUTING
iptables -t mangle -A POSTROUTING -o eth0.2 -j TTL --ttl-inc 1

Then redo the speed test. No matter what the result is, reboot the router, in order to undo the tweak.

Just to explain the (wrong) line of thought, here are my results with R7800:

speedtest from Chromium with dslreports 353.2 Mbps down / 802 Mbps up
speedtest from Chromium incognito tab with dslreports 357.3 Mbps down / 747 Mbps up
speedtest from Chromium against speedtest.net, Rostelecom server 390.60 Mbps down / 914.40 Mbps up
speedtest from incognito Chromium tab, Rostelecom server 787.60 Mbps down / 918.80 Mbps up
speedtest from the speedtest.net cli app, Rostelecom server 839.35 Mbps down / 936.22 Mbps up
speedtest from the speedtest.net cli app, TTK Ural server 683.19 Mbps down / 920.56 Mbps up, the difference is that I have less than 1 ms ping to Rostelecom and ~20 ms to TTK Ural.

See how unreliable and dependent on the exact benchmarking methodology the speed test result is? But you are right, I cannot refute the fact that the same methodology (browser) yields different results with and without the Archer in the middle.

How do you overclock the router?

1 Like

See [Solved] Archer C7 V2.0 Overclock

Do not overclock above 1000 MHz, otherwise there will be a significant clock drift. Regarding memory overclocking, it all depends on a particular instance of the router. One of my two Archer C7 v2 routers survives 760 MHz, and the other cannot handle 720. Regarding AHB bus speed, 333 MHz (that is, based on the CPU clock, and divided by 2+1) seems to work on both.

I followed this guide: [Solved] Archer C7 V2.0 Overclock

Don't remember what clocks I set for RAM and whatnot.

Overclocked the router gets slightly warmer but not hot. ARM routers get hot.

19.07.05 is out so I upgraded and reset config. Bare bones router with just changed admin password. Modem -> Router -> Ethernet connection to the laptop. Software offload is ON. I am getting the desired speed. BTW three speed tests show different results. Ranging from 530 -> 850 mpbs and 612 mpbs on DSLR. So it seems to be OK now. Next I will connect additional ethernet devices and my VLAN config to find the culprit if any. Screen Shot 2020-12-10 at 12.44.14 PM

1 Like

ag71xx as a driver is quite barebones. It doesn't have much in terms of optimization. Someone needs to fund development of it to get GRO support and whatnot.

Just remember that 2.4GHz WiFi is forever broken on Archer C7 v2. It works until it does not. Just disable it and use 5GHz. It is better in every way anyway.

Sorry to bump an old post, but this might be helpful to others.
I had a C7 v4 with version 18.06 and was facing the same issue. Upgraded my WAN speed to 500 Mb from 250 Mb and the router was only giving me 250 mb while the modem gave me 500 mb. I thought it was some buffer bloat config that I had done in the past, but I had no luck with qos and smq.

Found this post and followed your guys suggestion. Brand new 21.02 version barebones and... nothing.
Still got 250 MB on openwrt.

The key thing here is: Software flow offloading

As soon I turned on this featured. I received the correct download speed through openwrt. Thanks for sharing this knowledge with us.

1 Like

A question, (since I haven't taken the plunge w 21.02.0 on the home AP/router yet) are you able to run SQM successfully with software flow offloading?

I'm not a heavy user anymore, so I don't use SQM nowadays. Sorry.

I'm just happy to update my games at 500mb when they need.