Archer C7 V2 - Massive Problems

2.4GHz works if you have low bandwidth Internet, few devices and reboot it every night. But it falls apart if you start streaming stuff or have many devices attached to it.

The theory of ath10k using too much memory is not really plausible. My routers are configured as dumb AP's and worked just fine on 5GHz with 50% of memory free when 2.4GHz locked up. LUCI was accesible and you could Telnet to it, it just starts dropping packets or not allowing new clients to associate on 2.4GHz.

The issue seems to be in the firmware of ath9 device itself.

Does this limited mode work without any scripted reset workaround? I'm interrested in your wifi config to force this 56Mbit parameter.

1 Like

Hey guys, I'm running 18.06.2 on my Archer C7 V2 and I appear to have the same issue. 2.4GHz just slows way down over time, seemingly randomly.

I was hoping that upgrading to 19.07.2 would help, but it sounds like maybe not? Does everyone with our router have this problem?


I actually build my own for my Archer C7 V2, so I'm running off of Master build. However, I recently changed my ath10k drivers to use the kernel module kmod-ath10k and the firmware ath10k-firmware-qca988x. It has made a huge difference in the performance for the better for the 2.4GHz radio, and I have no issues with the 5GHz radio.

In addition, I have a CRON job that reboots the router at 4:30AM every morning, so when I get up, the router is running fresh.

Mind you, I just attach my IoT devices to the 2.4GHz channel and have my PC/iPad/etc. on the 5GHz channel.

NOTE: that's what's working for me. I only put this here for discussion purposes only. YMMV.

1 Like

I've recently upgraded to 19.07.3 , installed non-ct drivers and everything runs well (range, batman mesh, mesh + ap encryption, 2g+5g).

What is the throughput of ath10k without ct?

Using the ct versions of the ath10k drivers, I was getting about 52-64Mbps on my 2.4G channel. Switching to the non-ct versions, I'm now getting over 100Mbps on my 2.4G channel. These were tests I ran with my Macbook about 6 feet away from the Archer C7.

Note: I'm using my Archer C7 V2 as an AP with a Gigabit connection and OPNSense router. Usual disclaimer: YMMV.

Here is a listing of the ath10k drivers I'm using:

root@OpenWrt:~# opkg list-installed | grep ath10k
ath10k-firmware-qca988x - 2019-10-03-d622d160-1
kmod-ath10k - 4.19.115+5.4.27-1-3

Hope this helps.

Give this a spin see if it solves your problem

I just installed this lol see if it dies like everything else

Thanks for letting us know. Did you by any chance try it with stock 19.07.3 drivers? The release notes state that improvements were made for the Archer C7.

Also, which non-ct drivers did you install?



I just did

echo "[INFO] Switching WiFi firmware from ct to non-ct ..."
opkg remove ath10k-firmware-qca988x-ct kmod-ath10k-ct
opkg install ath10k-firmware-qca988x kmod-ath10k

echo "[INFO] Done. Reboot required."

... But cannot test ct drivers as then my encrypted mesh won't start. I don't understand why this only seems to be supported by non-ct drivers.

1 Like

Slightly better than -ct, measured on 5GHz. like 460Mbit/sec instead of 430MBit/sec iperf3 using 2x2 802.11ac radio at 80MHz channel width.

FYI: I just benchmarked this build and it used approx same amount of CPU% as stock OpenWRT while doing WLAN-LAN 5GHz iperf3 traffic (no routing, just wifi-to-ethernet). Is there some switch that needs to be toggled in order to enable HW acceleration? Also, is this acceleration only affecting NAT/routing or is there a possibility it can take some load of sirq?

It is only for LAN to WAN to do that activate SFE Offloading in Firewall

Hey Pocket_Sevens, where did you find that version of the kmod-ath10k driver? Mine seems to be older than yours.

root@OpenWrt:~# opkg list-installed | grep ath10k
ath10k-firmware-qca988x - 2019-10-03-d622d160-1
kmod-ath10k - 4.14.180+4.19.120-1-1

Hey @smeep. I build my firmware from the Master branch, so I'm guessing it's whatever is in the git repository. (My master build is using kernel version 4.19.115, so maybe that's why my kmod-ath10k driver is different.)

1 Like

So, it appears in my happiness of better throughput using the non-ct drivers that I've been seeing my 2.4GHz channel lock up lately. I put my IoT devices on my 2.4GHz channel and have all other devices attached to my 5GHz channel. Yet, it still seems to be locking up.

It seems that, no matter the driver set, we seem to be locking up.

So, to try and mitigate most of the headaches, I have the following setup:

  1. Archer C7 V2 running as an AP off of Master branch (version 4.19.115 kernel). I have no idea if the different kernel versions between 19.07.03 and Master causes a difference - I'd like your opinions.
  2. Cronjob that reboots the router every morning at 4.30AM. See the bottom of this page for the section called "Periodic reboot":
  3. 2.4GHz channel set to a width of 20MHz as recommended.
  4. WIFI24watchdog script to check to see if the 2.4GHz channel is locked up. If so, it brings down the 2.4GHz channel and restarts it. Post here: Archer C7 2.4 GHz wireless dies in 24~48 hours

I also am using Samba4 as I have an external drive attached as a NAS device. (Recently switched over from Samba3.6 since 3.6 doesn't seem to appear in the GIT repository anymore.)

This setup seems to give me a (relatively) headache-free experience. Any additional input would be greatly appreciated.

ksmbd will give better performance and lower CPU usage than samba.

1 Like

Hmm mine didn't lock up today but the wifi 2.4 range decreased significantly plus it accepted my phone, kicked it and reaccepted it and so on while a bad data rate occured. Rebooted my openwrt 19.07.3 archer c7 v2 (non ct) and range, signal , data rate was okay again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.