Archer C7 v2 EAP-MSCHAP v2 connection

Hello! I am sorry if this is too long of a post but i dont know how to explain it better.

I am new to this community and im trying my best to undestand and learn how to work with openwrt. I do not know whether this issue has been posted before but i couldnt find anything that might help a beginner like me. My university provides free internet alongside the accomodation. To connect to this internet we were instructed to go to ethernet settings (w10) and select microsoft peap->eap mschap v2 authentication method where we would enter a username and password(those being our student accounts mail/password). This method works perfectly but only connected via cable. I wanted to connect my phone and be able to use the laptop on the wifi so i asked around and other students said it was impossible/complicated to set up a wireless router. Another student posted a solution to this problem and i think it has worked for others but for me it didnt. It required to install openwrt on a compatible router and run a certain bash script to set up the connection. I have found myself an archer c7 v2 from tplink and successfully installed openwrt and the upgrade package on it. From there i managed to set up a hotspot on my phone so that i could connect the router to it because the script installed some packages and it needed internet access.

# This is a bash script that automatically installs and configures(hopefully) WPAD-OpenSSL on a router with OpenWrt installed.
echo "By running this script you take responsability in case anything wrong happens to your equipment"
echo -e "Do you wish to continue ? (yes/no): "
read consent
if [ $consent == "yes" ];
 echo "All previous configurations are being removed"
 /etc/init.d/wpa-autostart stop
 /etc/init.d/wpa-autostart disable
 rm -rf /etc/config/wpa.conf
 rm -rf /etc/init.d/wpa-autostart
 opkg update
 opkg install nano
 echo "The wpad and wpad mini packages are being deleted ( if they exist)"
 opkg remove wpad-mini
 opkg remove wpad
 echo "The wpad-openssl package is being installed "
 opkg install wpad-openssl
 echo "WPAD configuration"
 echo -e "Enter your student e-mail address:"
 read mail
 echo -e "Enter your student password "
 read psw
 cd /etc/config/
 cat > wpa.conf <<EOF
 echo "Router configuration"
 echo -e "Enter WAN interface name( visible in the OpenWrt menu) "
 read interface
 cd /etc/init.d/
 cat > wpa-autostart <<EOF
#!/bin/sh /etc/rc.common
# Copyright (C) 2007

start() {
echo start
wpa_supplicant -D wired -i $interface -c /etc/config/wpa.conf &
 echo "Connect your ethernet cable to the WAN port( if it is not already connected)"
 echo -e "Press enter to continue"
 read con
 ifdown $interface
 ifup $interface
 echo "The configuration has finished. Enjoy the internet"
 chmod +x /etc/init.d/wpa-autostart
 /etc/init.d/wpa-autostart enable
 /etc/init.d/wpa-autostart start

I have translated the instructions presented into english. I tried to run this script and i got prompted with some errors that the eap, identity, password fields do not exist. I have just made a factory reset on the openwrt client and i will follow any instructions you may give. Id be very glad if someone could help me set up this router. Thank you!

I can post any screenshots if needed

That script is not necessary. You can configure EAP connections using the OpenWrt web interface after installing the necessary package, which can also be done using the web interface.

Does your apartment have a wired Ethernet outlet? That is much simpler to set up and higher performance than a wifi link to a campus network.

Yes it does have a wired Ethernet outlet with 2 ports. Up until now i have used a cable to connect to the internet. Would it be possible to guide me to set up this connection ?

I have succeeded in connecting to the internet by using an archer c6 tutorial and modifying this script a bit. But now i have another issue. The speed should be gigabit(ive checked on cable before, around 900/900 download/upload speeds) and now i only get 150/160 on 5ghz wifi and 300/300 on cable connected to the first lan port. Also the 2.4ghz wifi doesnt work