Archer C7 v2 Bricked


Another one bites the dust...

I bricked my Archer C7 V2 (US), exactly the same way than @alex45 on this topic:

Another archer C7 v2 bricked :(

but the file he shared is not available. I tried will all the firmwares I could find, webrevert, stock, the ones from the wiki, ddwrt, nothing seems to work.

This is the only data I could get:

I could connect the header on the serial port but coms just dies after booting and after trying all day, now I get less data. I tried with different ttl-usb, finally I used a signal analyzer I have, and it just show the serial port stop working.

. Here is a video with the issue:

Any Ideas? Following the wiki it seems my only hope is JTAG? I have never used JTAG before, can it be done with a Raspberry pico?

I have a tplink wdr7500v3 and change its flash to 16M,now I use the same firmware of archer c7 v2.I use a bootloader named breed instead of u-boot.I dont know other ways to fixed your problem except use a flash programer.It maybe flashed by jtag,I have forgotten how to use jtag to recovery the devices

the breed support many kinds of firmware like openwrt,ddwrt,offical

thank you, but still the same issue, It won't flash. I Will be reading about breed.

That looks like hardware failure, especially if it doesn't do exactly the same thing every time you boot. Try pressing down (lightly) on the CPU and RAM chips while booting. If that changes it to go farther in the bootup you may be able to reflow the BGA solder.

It is doing the same thing showing the exact same data as the video, just after the first time and trying flashing different things and using different ttl-usb it changed.

An update on my journey to try to recover.

I succesfully got jtag and ran it. I can connect to the device, but it is not detecting the spi. When I send the command "flash probe 0" I get no response. When I send "flash info 0" I get "auto_probe failed"

In this page I see the flash chip is Winbond 25Q128FVSG, but I see my chip is GD 25Q128CSIG

Any ideas how to proceed? My guess is something with the ath79.cfg file, I got it from here

Finally I could install the breed bin from the link you shared with jtag after some hours trying, reviewin wiring, but don't know what really made the trick. Thank you!
Any advice or suggestion with breed?

Edit: Don't get the part in here saying " After updating the AR / QCA chip from U-Boot to Breed, please remember to check whether the MAC address is valid. If it is all FF, please modify it yourself! !!"

Should I input anything there or there is any rule ?

view images

1.TP-LINK 设置------mac----change to anyone except all ff

all ff is occupied by the broadcast addr ,so conflict
this mac may be used for lan ,and the wan's or radio maybe +1 or +2 or -1 or -2

2.also,it is better making a reset :恢复出厂设置-----

1.TP-LINK(原厂):means making a reset if it is OEM firmware
4.....sdk.. I dont know about it,it may be better not do anything about the sdk settings

Use the unit's factory assigned MAC from the sticker on the bottom.