Archer C7 V2 - Bin File Won't Load

Model TP Link Archer C7 V2 3.15.2 Build 170525 Rel.37571n - trying to install "lede-17.01.4-ar71xx-generic-archer-c7-v2-squashfs-factory.bin"

The Archer will not install the file with an error, paraphrasing, "Wrong file". Is there a workaround for this? My assumption is that is does not like the file name. Could I shorten it to "factory.bin"?

Any help is always appreciated.

Try renaming the file factory.bin, otherwise you may need to use TFTP.

TFTP tutorials…

Shortened link was a bust but I Googled it and found the tutorial. I'll try both tomorrow with a bit of hesitation on the TFTP method.

shouldnt you have just used the sysupgrade.bin file? or was this from a factory firmware?

The router has never had anything but the stock firmware loaded. From my reading I assumed that the sysupgrade.bin was only for upgrading previous LEDE installs?

However, I have read that TP Link is not thrilled about aftermarket firmware's. Could something in the router actually be blocking the install of a non factory firmware?

It's in the stock firmware header.

So when you say say "It's in the stock firmware header" you are referring to the stock firmware preventing an upload of anything non stock? In my last post I said the router was preventing it but that was a quick work time blurb and I did mean the stock firmware preventing anything else from loading.

Someone has done this before or I imagine they wouldn't create Lede firmware. I would be interested to know how it was done.

  1. Flash first with an older version of the stock firmware that does not have the modified header. Then flash with 3rd party firmware (not limited to LEDE alone).

  2. Use TFTP.

Even though your router is not “bricked”, this tutorial works for upgrades as well…

In your case, you would rename the LEDE firmware file archerC7v2_tp_recovery.bin

i never had issues with the archer c7 v2 flashing from firmware via the web browser, with the factory binary then sysupgrade from there after for customized or even updated binaries with different packages and modules.

As of around December 2015, the stock firmware header was modified for routers sold in the U.S.

Earlier versions of the firmware don't have the mod.

well i just bought mine off amazon like 3 weeks ago, works great with this

DD-WRT solved it by modifying their header to pass the check.

The "optimized" probably did the same thing...

I actually tried a fork that I found on this site and I believe it was a region (US) issue. As soon as I flashed the firmware with the US in the name it worked???

I am actually using the version sycohexor is using. Had already found and loaded the firmware but thanks for the heads up!

I get around it by renaming an older firmware release to archerC7v2_tp_recovery.bin and using TFTP to get back to stock.

Did it just yesterday for a router that needed to go back.

Then renamed the specific LEDE squash factory bin to factory.bin, and flashed it through the stock web GUI.

jwoods.....appreciated. I don't mind the accidental brick (although annoying) but the family is using the router and I don't need the extra aggravation. Thanks for all of your help!

Glad you got it sorted.

1 Like

I bought this router, because it was in the recommended routers.

Is that page just never updated? I'd really rather not patronize companies that are going to try to prevent you from modifying your own hardware.

What page? You mean the recommended hardware page? That's based on the technical specs and other factors.

I'm not sure what companies you refer to. I believe TP-Link is one of the companies that has a very large number of supported routers already. Moreover issues with porting is mostly related to the chip sets (i.e. the manufacturer of the internal components) not the devices.

Please don't use old topics to post new questions, as this makes the forum messy. It's best to open a new topic.

What page? You mean the recommended hardware page? That's based on the technical specs and other factors.

Sorry, I figured out this problem, and it turns out I was using the wrong release.

When I used the right release (v5), everything works beautifully. Well done.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.