Archer c7 V2 5Ghz wifi not working

Hi everyone,

I'm new to the LEDE porject, I'm trying to set up the 5Ghz wifi, I have tried auto settings and custom random channels settings none worked for me.

I got this message:
"Wireless is disabled or not associated"

  • 2.4Ghz worked like a charm, don't see why there should be any conceptual differences between the setup of those two


What version of LEDE are you on (I saw your other post on r00t's thread, is it his custom build or LEDE final)? Did you set your country code?

Also I've noticed something similar: After 3 tries changing the 5Ghz channel, it crashes and I have to reboot.

I've noticed DFS channels don't work, despite the device saying that it's working.

As for the difference, it's all down to drivers.

I'm using LEDE finale. I didn't changed the country code, I used US in dd-wrt to gain more signal distance (so was thinking of doing the same here), I'll try this evening to change it and see if it's helps.


Also try to use a non DFS channel like channel 40, as per @neheb comment. Then reboot when it has been changed.

Changing the country + channel to 40 seems to work, got 20Mbps in the farthest place from the router.
Hope it will stay stable.

Thanks everyone.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.