Archer C7 v2 - 5 GHz AC wireless not showing on some devices

Hi All,

Being a bit dissapointed with Gargoyle performance after getting a new internet connection (FTTH 250/20 Mbps) I decied to try Lede.

I am pleased with performance but noticed that 5 GHz network is not showing up on my Galaxy Note4 (SM-910C). Tried to change the regulatory domain but looks like any single change in Luci regarding regulatory domain is causing 5 GHz to stop operating at all. I am getting the message "wireless is disabled or not associated" in Luci.

My current config below, any thought or hints are welcome.

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'pci0000:01/0000:01:00.0'
option htmode 'VHT80'
option txpower '23'
option country 'US'
option channel '161'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid '***'
option encryption 'psk2'
option key '***'

I'd suggest to try a non-DFS, lower, channel (36-48) first. Mostly for two reasons, on the one hand it takes a while before a DFS channel becomes available (as the AP has to listen passively for radar pulses for a certain amount of time first, if there is a radar in range, it won't become available at all) and on the other hand not all clients support all higher DFS channels.

Thanks for a prompt reply! So I set AC iface to ch48. It worked and showed up on my Note4. A short performance test showed that this is gives me max ~15 MB/s to my NAS (previously I was able to hit 30-35, usually sth between 22-30 MB/s).

I was able to find a few channels between 48 and 100 (or 132) that provided accessibility on both the laptop and the phone. However the ac wireless speed was always lower than on 161.

So as I need a better performing network on my laptop then my phone I will stick to 161 channel and hook up the Note4 on the 2.4 network.