Archer C7 v2/5: Cannot setup mesh beside AP SSIDs with wpad-mesh

Hi,

I still can't setup 802.1s (unencrypted), have tried several ways and was recommended by @mk24 to use 802.1s instead of IBSS oder AP-STA to build up a mesh.

Firmware: OpenWrt 19.07.0 release

/etc/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option txpower '20'
	option country 'DE'
	option legacy_rates '0'
	option noscan '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/ahb:apb/18100000.wmac'
	option channel '1'
	option htmode 'HT40'
	option country 'DE'
	option legacy_rates '0'
	option noscan '1'
	option txpower '20'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'WLANHST'
	option network 'VL50'
	option disassoc_low_ack '0'
	option encryption 'wpa2+ccmp'
	option auth_server '10.20.10.11'
	option auth_port '1812'
	option acct_server '10.20.10.11'
	option acct_port '1813'
	option nasid 'WLANHST'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option auth_secret ''
	option acct_secret ''

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WLANHST'
	option network 'VL50'
	option disassoc_low_ack '0'
	option encryption 'wpa2+ccmp'
	option auth_server '10.20.10.11'
	option auth_port '1812'
	option acct_server '10.20.10.11'
	option acct_port '1813'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option auth_secret ''
	option acct_secret ''
	option nasid 'WLANHST'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'WLANHST-ESE'
	option disassoc_low_ack '0'
	option encryption 'psk2+ccmp'
	option key ''
	option nasid 'WLANHST-ESE'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option network 'VL40'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WLANHST-ESE'
	option disassoc_low_ack '0'
	option encryption 'psk2+ccmp'
	option key ''
	option nasid 'WLANHST-ESE'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option network 'VL40'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'ap'
	option ssid 'WLANHST-IT'
	option disassoc_low_ack '0'
	option encryption 'wpa2+ccmp'
	option auth_server '10.20.10.11'
	option auth_port '1812'
	option auth_secret ''
	option acct_server '10.20.10.11'
	option acct_port '1813'
	option acct_secret ''
	option nasid 'WLANHST-IT'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option network 'VL30'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WLANHST-IT'
	option disassoc_low_ack '0'
	option encryption 'wpa2+ccmp'
	option auth_server '10.20.10.11'
	option auth_port '1812'
	option auth_secret ''
	option acct_server '10.20.10.11'
	option acct_port '1813'
	option acct_secret ''
	option nasid 'WLANHST-IT'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option network 'VL30'

config wifi-iface 'wifinet6'
	option device 'radio0'
	option mode 'ap'
	option ssid 'CHROMECAST'
	option network 'VL50'
	option macfilter 'allow'
	list maclist '3c:8d:20:3a:1f:6a'
	option disassoc_low_ack '0'
	option encryption 'psk2+ccmp'
	option key ''
	option nasid 'CHROMECAST'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet7'
	option device 'radio1'
	option mode 'ap'
	option ssid 'CHROMECAST'
	option network 'VL50'
	option macfilter 'allow'
	list maclist '3c:8d:20:3a:1f:6a'
	option disassoc_low_ack '0'
	option encryption 'psk2+ccmp'
	option key ''
	option nasid 'CHROMECAST'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet8'
	option device 'radio0'
	option mode 'ap'
	option encryption 'none'
	option ssid 'WLANHST-GAST'
	option disassoc_low_ack '0'
	option network 'VL134'

config wifi-iface 'wifinet9'
	option device 'radio1'
	option mode 'ap'
	option encryption 'none'
	option ssid 'WLANHST-GAST'
	option disassoc_low_ack '0'
	option network 'VL134'

config wifi-iface 'wifinet10'
	option device 'radio0'
	option key ''
	option mode 'mesh'
	option mesh_id 'test555a'
	option mesh_fwding '0'
	option mesh_rssi_threshold '0'
	option disassoc_low_ack '0'
	option network 'nwi_mesh0'
	option dtim_period '1'
	option encryption 'none'

Screenshot:

All other SSID's work, just as before the mesh was added.

I've replaced "wpad-basic" with "wpad-mesh". No error on opkg installation (had an dependency error before on 19.07-rc.2).

logread:

Wed Jan  8 12:28:59 2020 kern.info kernel: [   12.965122] ath10k 4.19 driver, optimized for CT firmware, probing pci device: 0x3c.
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   12.974306] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
Wed Jan  8 12:28:59 2020 kern.info kernel: [   12.980230] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.268607] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:00:00.0.txt failed with error -2
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.279319] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:28:59 2020 kern.err kernel: [   13.514153] firmware ath10k!fwcfg-pci-0000:00:00.0.txt: firmware_loading_store: map pages failed
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.523344] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.534230] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:28:59 2020 kern.err kernel: [   13.716117] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.727929] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-5.bin failed with error -2
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.739087] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:28:59 2020 kern.err kernel: [   13.920563] firmware ath10k!QCA988X!hw2.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.930182] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-2.bin failed with error -2
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   13.941332] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:28:59 2020 kern.err kernel: [   14.156046] firmware ath10k!QCA988X!hw2.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:28:59 2020 kern.warn kernel: [   14.165673] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   14.176556] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:29:00 2020 kern.err kernel: [   14.356335] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   14.365699] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   14.376580] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:29:00 2020 kern.err kernel: [   14.559030] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   14.568389] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with error -2
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   14.579270] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:29:00 2020 kern.err kernel: [   14.778720] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   14.788104] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   14.798989] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:29:00 2020 kern.err kernel: [   14.980361] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:29:00 2020 kern.info kernel: [   14.992820] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
Wed Jan  8 12:29:00 2020 kern.info kernel: [   15.002218] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
Wed Jan  8 12:29:00 2020 kern.info kernel: [   15.014641] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-8x-__fW-022-b0e1b7cd api 2 features wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 1e527180
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   15.127133] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   15.137749] ath10k_pci 0000:00:00.0: Falling back to user helper
Wed Jan  8 12:29:00 2020 kern.err kernel: [   15.256427] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
Wed Jan  8 12:29:00 2020 kern.info kernel: [   15.265684] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Wed Jan  8 12:29:00 2020 kern.warn kernel: [   16.321941] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Wed Jan  8 12:29:00 2020 kern.info kernel: [   16.339394] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Wed Jan  8 12:29:00 2020 kern.info kernel: [   16.345723] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Wed Jan  8 12:29:00 2020 kern.info kernel: [   16.353847] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20904 iram: 26056'
Wed Jan  8 12:29:00 2020 kern.info kernel: [   16.421871] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
Wed Jan  8 12:29:00 2020 kern.info kernel: [   16.434672] ath10k_pci 0000:00:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.567066] ath: EEPROM regdomain: 0x0
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.567073] ath: EEPROM indicates default country code should be used
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.567076] ath: doing EEPROM country->regdmn map search
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.567089] ath: country maps to regdmn code: 0x3a
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.567094] ath: Country alpha2 being used: US
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.567097] ath: Regpair used: 0x3a
Wed Jan  8 12:29:00 2020 kern.info kernel: [   16.875904] batman_adv: B.A.T.M.A.N. advanced openwrt-2019.2-5 (compatibility version 15) loaded
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.906666] ath: EEPROM regdomain: 0x0
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.906673] ath: EEPROM indicates default country code should be used
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.906676] ath: doing EEPROM country->regdmn map search
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.906689] ath: country maps to regdmn code: 0x3a
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.906694] ath: Country alpha2 being used: US
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.906697] ath: Regpair used: 0x3a
Wed Jan  8 12:29:00 2020 kern.debug kernel: [   16.924269] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Wed Jan  8 12:29:00 2020 kern.info kernel: [   16.925737] ieee80211 phy1: Atheros AR9550 Rev:0 mem=0xb8100000, irq=13
Wed Jan  8 12:29:00 2020 user.info kernel: [   16.954579] kmodloader: done loading kernel modules from /etc/modules.d/*

Ok, I've found a solution. (Took it from: https://forum.openwrt.org/t/tp-link-archer-c60-v2-19-07-0-rc2-ath79-snapshot-out-of-memory )

Archer C7 v2 / v5 - Connect via SSH and change firmware packages for the radio0 5 GHz interface:

  • opkg remove ath10k-firmware-qca988x-ct kmod-ath10k-ct
  • opkg update
  • opkg install ath10k-firmware-qca988x kmod-ath10k
  • rmmod ath10k_pci; sleep 1; modprobe ath10k_pci
  • -OR- reboot

I'm able to run multiple AP SSID's and a mesh SSID with WPA3-SAE encryption simultaneously with the non-ct firmware packages.

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option txpower '20'
	option country 'DE'
	option legacy_rates '0'
	option noscan '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/ahb:apb/18100000.wmac'
	option channel '1'
	option htmode 'HT40'
	option country 'DE'
	option legacy_rates '0'
	option noscan '1'
	option txpower '20'

....

config wifi-iface 'wifinet9'
	option device 'radio0'
	option mode 'ap'
	option encryption 'none'
	option ssid 'WLANHST-GAST'
	option disassoc_low_ack '0'
	option network 'VL134'

config wifi-iface 'wifinet10'
	option network 'nwi_mesh0'
	option mesh_rssi_threshold '0'
	option key 'MYSECRETKEY'
	option encryption 'sae'
	option device 'radio0'
	option mode 'mesh'
	option mesh_fwding '0'
	option mesh_id 'test_mesh_ssid'

This requires /etc/config/network to have the interface "nwi_mesh0".

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.