Archer C7 V1.0 ART dump

I found dumpArcherC7v1.bin in iXBT and here but the ART part is missing the 5 GHz
radio (QCA9880). If anyone using latest OpenWRT in an old Archer C7 V1.0 it can be
dumped using "Save mtdblock contents" in Flash in System > Backup / Flash Firmware.


The ART partition is device specific. Each unit will have parameters saved into the ART partition that are generated from the manufacturing line test and calibration process as each device is built. They are unique to every device and account for the manufacturing variability of the RF circuitry and the antennas.

The ART partition from someone else's device may technically restore your 5G radio, but it will not be optimized. In some cases, it may end up with lower performance than expected, and in other situations, you might run the device out of spec with respect to regulatory requirements (thus it could be technically illegal).

The QCA9880-AR1A wireless chipset present on the archer c7 v1 isn't supported by ath10k or OpenWrt either way (only the second generation silicon, QCA9880-BR4A shipping since v2 of the archer c7 is).

It seens the QCA9880-AR1A bootloop issue was already fixed in current OpenWRT (21.02) and the previous version (18.06.9) was also working fine. The problem is that WPA2-EAP seens to be broken in latest versions and when performing a downgrade the ART partition was corrupted. I recovered the 2.4 GHZ radio using the whole dump from iXBT forum this file is missing the 5 GHz ART (all FFFFFFFFh).

bootloop, yes - functional QCA9880-AR1A support, no. It is not and has never been supported.

The 5 GHz radio is a PCIe card on these and I think the 5 GHz ART is stored in an EEPROM on that card, not in the main flash. Not that that will help you here since the chip is not supported.

Somehow I had 5 GHz working with both 18.06.9 (with WPA2-PSK and WPA-EAP) and 21.02 (only WPA-PSK). Here is the whole scenario, so maybe it help others not fall in the same boat:

  1. Original: 18.06.9 - Working 2.4 GHz and 5 GHz both with WPA2-PSK and WPA2-EAP (wpad).
  2. Upgrade: 21.02.1 - Working 2.4 GHz and 5 GHz with WPA-PSK but WPA2-EAP was broken (tried wpad, wpad-wolfssl, wpad-openssl, clear all configuration and decided to revert back to 18.06.9).
  3. Downgrade: 18.06.9 - No radios detected (both 2.4 GHz and 5 GHz). Only cable is working.
  4. Revert to factory - Still no radio.
  5. Revert to 21.02.1 and flash ART extract from iXBT dump - Partial success (got back the 2.4 GHz (WPA2-EAP is still broken and I´m still looking for the 5 GHz ART file or how get the radio back online).

Original: "iw list" shows Wiphy phy0 (2.4 GHz) and phy1 (5 GHz) with both firmwares
Current: "iw list" shows only Wiphy phy0 (2.4 GHz, that is after flashing the partial ART file from iXBT V1 dump - found it here)