Archer C7 network setup issues

Hi guys, I have been trying to get set up with a new archer C7 v5. I can't seem to make any progress.
I would like to use the c7 to run a VPN (pptp or openvpn) and have devices connect to the c7 WiFi if I want VPN otherwise use my current setup which is Google WiFi.
The issues I have are:

  1. I can't connect to my pppoe ISP at all. I enter username and password in wan and it will not connect. Using the tplink firmware it connects immediately.
  2. I gave up on pptp and just tried assigning a static IP and connecting Lan to lan. This works to a certain extent but I can't install any VPN packages. I found a guide for pptp and it says click update lists then install a few different packages from the list. The problem is update lists doesn't work and not all the packages are in the list so I can't proceed.

I tried DHCP client but that didn't work at all, I'm not sure if that's what I should be using instead of static IP or not.

I'm not great at this stuff, but in not a total noob either. My skills really only extend to following guides though and I can't find anything to help me.

Thanks in advance for any assistance.