Archer C7 - luci-app-sqm (18.06 download trouble)

Installed 18.06.2 on my Archer C7 V2 just a bit ago and am trying to install luci-app-sqm. Upon trying to install this I receive this error:

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-sqm:
 * 	tc
 * opkg_install_cmd: Cannot install package luci-app-sqm.

How do I go about fixing this so I can get sqm installed?

its traffic control dependency that i dont know what has happened to it, some routers still have it in their packages but others dont. I am not sure what the reason to this is

Try again.

There was was major trouble regarding 18.06 download "base" repo where "tc" is located. There are several threads about "base" package repository 403 access...

It should have been now fixed and the repo should again be usable for downloads sine a few minutes ago. Just do "opkg update" and then try reinstalling the package.

1 Like

Thanks for the reply. Forgive my ignorance, but how do I go about running "okpg update"? Do I run it from somewhere inside the LuCI interface or do I need to SSH into the router? I am fairly new to OpenWRT, but I know some of the basics. Thanks so much!

Many advanced users work with the command line as primary. The equivalent in LuCI is to refresh the list of available software packages on the same page you tried to install it from before and then try installing it again.


Ah I understand. Originally after flash I had the update button and pressed that then tried to install it, but got the error that I posted. Going back to the software page I do not have an update button anymore and trying to install it again I get the same error even after refreshing and logging out and back in. Should I try a reboot and see if the update button shows up again?

You could try that, and/or using a different browser in case something stuck in the cache.

1 Like

I did both. I rebooted and tried a different browser and it looks like that did the trick. I was able to see the Update Lists button, pressed that and search for the luci-app-sqm. Clicked install and voila:

Installing luci-app-sqm (1.2.4-1) to root...
Installing kmod-sched-core (4.9.152-1) to root...
Installing libmnl (1.0.4-1) to root...
Installing tc (4.16.0-8) to root...
Installing kmod-sched-cake (4.9.152+2019-01-08-331ac70c-1) to root...
Installing kmod-ifb (4.9.152-1) to root...
Installing kmod-ipt-ipopt (4.9.152-1) to root...
Installing iptables-mod-ipopt (1.6.2-1) to root...
Installing kmod-ipt-conntrack-extra (4.9.152-1) to root...
Installing iptables-mod-conntrack-extra (1.6.2-1) to root...
Installing sqm-scripts (1.2.4-1) to root...
Configuring libmnl.
Configuring kmod-ipt-conntrack-extra.
Configuring kmod-sched-core.
Configuring tc.
Configuring kmod-ipt-ipopt.
Configuring iptables-mod-ipopt.
Configuring kmod-sched-cake.
Configuring kmod-ifb.
Configuring iptables-mod-conntrack-extra.
Configuring sqm-scripts.
Configuring luci-app-sqm.

Thank you everyone for your input on this!

1 Like

@shady06x Welcome.

If your issue is solved, please mark the post with the solution by ticking the box underneath it, as shown in the image below.

By the way, for the sake of the tidiness of the forum, please always use the Pre-formatted text tool </> when including code in the post.

Sorry about that! Thanks for the heads up.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.