Archer C7 - iPhone - slow

I've been using LEDE for half a year now. Occasionally I install the snapshot from the buildbot.
At the moment I have installed: "LEDE Reboot SNAPSHOT r2966-0d8381a".

Since a few weeks I'm having "speed' problems on my iPhone 6S.
Doing speedtest I'm running 20 - 25Mbit max, this is 2 - 3 metres from the Archer C7.
Before I ran into the 65 - 70Mbit.

First I thought it was my jailbroken iPhone 6S (iOS 9.0.2) but my GF got a brand new iPhone 7 (iOS 10.2) which is having the same problems...

Wifi: 2.4GHz
Operation mode: N
Channel: 6
Country Code: US
Channel width: 40MHz
Transmit power: 25dBm
Wifi encryption: WPA2 PSK (CCMP)

I have set "option noscan 1" manually in the wireless config file.

When I check the associated stations my Iphone is connected with the following details:

24.0 Mbit/s, 20MHz
144.4 Mbit/s, 20MHz, MCS 15, Short GI

Is there something changed in the latest snapshots causing this issue?
I have checked surrounding wifi networks. There is nothing changed. Channel 6 is still the best channel to use.

Any tips are welcome! :slight_smile:

Any one have a clue?


I think, speedtest websites aren't the best way to test the network speed, because it depends on your internet connection speed and on the speed of the speedtest server. if the server is under heavy load, you get bad results.


I understand but I don't know another way to test with my phone.
Besides when I enable 5GHz on my router I will get full 150mbit on my downloads.
So there is nothing wrong with the internet connection, it's the 2.4GHz band on my LEDE router that is causing the slow speeds.

Did you check your syslog? Is there something like:
daemon.notice netifd: radio0 (2651): 20/40 MHz operation not permitted on channel pri=13 sec=9 based on overlapping BSSes

Another way to test your phone:
I don't own an Iphone but you could check if there is an iperf client in the Appstore. If that is the case you could set up an iperf server on a LAN cable connected PC/Laptop to test the speed.

Thanks for the reply.
There is no such message in the logs.

I've tried a few iperf apps in the appstore all which do no work properly...
I guess this is a lost game than...

Could you please try the latest snapshot? I just noticed there were some recent wifi driver changes like;a=commit;h=6b013019f9886ee1cda8a48d5b01009527136802

I just installed the latest build for the Archer C7
LEDE Reboot SNAPSHOT r3128-b94177e -- Wed Jan 25 19:35:53 2017

Still the same problem.
Getting speeds around 25 - 30 mbit max on the iPhones... (on 2.4GHz band).

After a reboot on my iPhone I do get good speeds again!