Archer C7 C1750 V2 died

I own the nbg6817 and am very happy with it, in current master (snapshots) the firmware can be flashed from the OEM webinterface (see "OpenWrt master newer than r7959-g8e9a59a6b9 (2018-08-28)"), the nbg6817 also offers a 2*(4+64) MB dualboot setup (and a reliable tftp based recovery).


Sounds amazing @slh - I think I'm just going to go pick up a nbg6817

Am I correctly reading, that, I can flash this openwrt-ipq806x-zyxel_nbg6817-squashfs-factory.bin from the stock webinterface of the router?

The two firmware links in the top are both different though, squashfs-mmcblk0p4-kernel.bin and squashfs-mmcblk0p5-rootfs.bin

I'm probably being stupid and just not reading everything, but is the bin file I need either of those two?

The procedure differs between 17.01.x/ 18.06.x and current master (snapshots) or the upcoming 19.03.0.

I'd strongly recommend to first flash a current master snapshot ( from the OEM webinterface (just like you'd update to a newer OEM firmware) and ignore anything said about 17.01.x/ 18.06.x (or squashfs-mmcblk0p4-kernel.bin/ squashfs-mmcblk0p5-rootfs.bin, that is no longer necessary or even available in master).

If you then decide to stick to master (and install the webinterface/ luci manually) until 19.03.0 or want to downgrade to (sysupgrade -n openwrt-18.06.2-ipq806x-zyxel_nbg6817-squashfs-sysupgrade.bin) is a matter of personal preference. Personally I'm sticking to master.

This only matters for the first installation from the OEM firmware, as the convenient factory installation method only became available after 18.06.x was released.


Seems easy enough when you put it that way.
Flash current master from webinterface, install LuCi manually, update to 19.03.0 when that is released?

Since i've only ever used the LuCi interface to install software, is there a link to a guide for installing LuCi manually?

will this be good to follow?

Yes, that should work.

Another alternative would be to use a recent enough community build for the initial installation (newer than 18.06.x/ 2018-08-28, new enough, but including luci): Optimized build for the TP-Link C2600 / Netgear R7x00 / Linksys EA8500 / Zyxel Armor Z2

1 Like

Thanks so much for the help. I'll be doing all of this ASAP tomorrow morning.

Wish you a very good nights sleep!

Okay, so..

I got the new Zyxel Armor Z2 up and running, I got the newest snapshot and SSH installed LuCi.
It's working very well.

Though, my main issue is actually still present. Lol. I thought it was gone, but it was just a lucky few days.

The last two days I've had random DC's again, where the entire internet cuts out for 2-5seconds at a time (just bordering on the disconnect timer in Path of Exile).

I've got no idea what it is, and I don't have any idea where to start troubleshooting.

I've had contact with my ISP 3 times now and they've said each time that there's nothing wrong that they can see. The next time I call they'll be sending a technician, and if it's my hardware or cables, I have to pay the insane bill.

Any ideas what I can do?
It's the exact same issue as the old Archer C7. So that router is probably not even dead :frowning:
I tried plugging the cable directly into the PC from the wall, and the day or so I tested there was no lag/DC at all, but then again it's so random.

What to do.. aghh!

Other than change ISPs? (Yeah, I know)

If their tech support's first question is "Which version of Windows are you running?" there isn't much hope.

Monitoring your modem's signal levels would be helpful.

Monitoring ping out to their router, to a reliable host outside of their border, and perhaps inward from outside of their border at least will let you know what is happening. If it is within their border, it may take a long time to get to anyone that cares, not to mention is competent to resolve it.

(None of this is "special" when it comes to OpenWrt.)

The thing is when I tried to go around the router, there was no problem (but that might just be because I couldn't test for more than 18 ish hours)

When I ran PingPlotter, any server that I tried to ping would just red bar completely whenever we lost connection to the game. YouTube would stop buffering and everything else of course.. Like everything just stopped.
Router? I don't know.. Doubt it could be routers twice in a row, right?
And it can't be the cable, because that wouldn't be random either, right?

Could you, now that you have two routers, put one of them after the other LAN --> WAN, so that both are actually routing, and then run this PingPlotter overnight via the client router to both the main router and an internet server. If both fails then it's an issue with the router or the cable. If pinning the main router works while pining a server doesn't then it's likely to be at the ISP side (or if it's at your side then it's likely to be with the PPPoE settings you use).

Unfortunately intermittent connectivity issues that aren't happening right now when you call the ISP are hard to debug (and you'd have to pray that it still persists when the field technician is around, or you'd have to pay for their visit), but you can still try to trace the issues to external factors (wind, rain, etc.) - maybe that helps (although that won't really give you a solution either).

which firmware did you run on dir615? how often you updated archer? sounds like software issue

So good news.
It's not any of the routers.


This is what just happened on a direct cable connection from the wall, PingPlotter.. and the game also froze during this time.

Red bars = no pings going through, 100% packet loss..

Anyone got ideas?
I mean at this point the ISP should really just be like "yeah, this is a problem on our end" right?
It can't be anything on my end... yeah?

Goddamnit this is frustrating...

thanks for the help so far guys.

and just now again

Puma chip in your modem?

in my modem?
I dont know what you're referring to.. but there's nothing powered on the wall, it's just an ethernet plug
i'm bypassing the router right now with a direct cable to it and the packet loss is still happening

try again if it's happening with dir615. maybe it's raining and you have water in cables like we used to and stupid uneducated technicians always said everything is fine. until one winter it freeze and broke cable completely

The Puma chip used in DOCSIS modems is notorious for “lag spikes”.

right now im ok with keeping the Zyxel Armor Z2
i have the Archer C7 as a backup just in case
but yeah it must be something they broke i guess...