Archer C7 AC1750 v2 in China

I'm in China and have a Chinese version of the Archer C7 AC1750 (TL-WDR7400) v2 onto which I want to install LEDE. However, when I try to flash from the stock TP-Link interface, it says "发送请求失败,请重试" which indicates failure. I've tried several varieties of firmware, including OpenWRT and the "optimized" version of LEDE from github/infinitnet; they all give the same error.

I understand the stock TP-Link does some region checking on firmware uploads, which is perhaps what's causing it to reject uploads? Does anyone have any suggestions about how to proceed? Thanks!

Please, provide link to stock firmware file.

Please, provide link to stock firmware file.

Thanks for replying! This router has never been upgraded; it's running the factory default. I looked for a while but my Chinese isn't good enough to find the firmware downloads page on - is that what you want to find, a link to download the TP-Link stock firmware?

Based on Wiki, TL-WDR7400 v2 doesn't share Archer C7 v2 US/EU hardware design, it looks more like the C7 v4. Don't try to flash it with a wrong firmware.

I found firmware here: It uses different layout than in case of C7 v4, so you probably need to make separate support for your board.

Interesting, thanks. I wonder if all the Chinese versions of Archer routers are so different from EU/US versions? I also have a Chinese AC-1300 (TL-WDR6500) v6.

In general, yes they are different. And what's more, most of them use signed firmware which prevents (easy or at all) alternative firmware flashing.

Archer C7 AC1750 Wireless Dual Band Gigabit Router Archer C7
Qualcomm Atheros QCA9563+QCA9880+QCA8337N(Switch),128MB RAM,16MB SPI FLASH

TL-WDR7400 v2 None Gigabit version
Qualcomm Atheros QCA9561+9880,64MB RAM,8MB SPI FLASH

TL-WDR7400 v2 Gigabit version use MTK

So the parameters of these two hardware are quite different