Archer C7 AC1750 "Please choose a file to upgrade!" error when trying to flash

Hello everyone,
I keep getting the above error when trying to flash with the factory.bin file. I can browse the file no problem, but can't get past the above when I hit "Upgrade." I'm on Ubuntu 18.04 and using Firefox to connect to the router.
Not sure if I'm missing something obvious. Any help appreciated.
Many thanks!
W

1 Like

@wint3r, welcome to the community!

  • Have you tried another browser?
  • Have you tired other client?
  • Have you disabled any Ad or Script blockers?

Also, per the community guidelines , please refrain from signing posts.

Thanks for the reply and info. Will read. Soz about the signing.

Ok. Tried again in windows, using different browsers. Same message each time. I am wondering if I should upgrade the stock firmware before trying again?

Have you tried shortening the name of the factory.bin file?

I have not. What would you suggest?
Edit to add: it seems to have accepted the TP Link upgrade without a problem.

From https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500#quick_start_guide

If the web interface tells you 'Please choose a file to upgrade', just rename the file to something shorter like openwrt.bin

1 Like

Thank you! Will give that a go.

Done! My thanks to you. I also picked a great day to do this--my internet service has been an absolute pain flickering in and out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.