Archer C7 5Ghz radio not active/working

Just flashed OpenWRT 19.07.3 on my Archer C7 v5, and the 2.4ghz works flawlessly (so far at least), but the 5ghz channel isn't working. radio0 shows Qualcomm Atheros QCA9880 802.11nac and says Device is not active. I added the access point to it, and under the access point it says Wireless is not associated, but if I click edit on the access point it says at the top SSID (radio0.network1) which is the 5ghz radio I believe.

/etc/config/wireless shows

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'US'
        option legacy_rates '0'
        option channel '36'
        option htmode 'VHT40'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option country 'US'
        option legacy_rates '0'
        option htmode 'HT40'
        option channel '6'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key ''****''
        option ssid '@@@@'
        option encryption 'psk2+ccmp'

config wifi-iface 'wifinet1'
        option ssid '@@@@'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option key ''****''
        list maclist ''****''
        option macfilter 'allow'
        option encryption 'psk2+ccmp'

config wifi-iface 'wifinet2'
        option network 'lan'
        option ssid '@@@@'
        option device 'radio1'
        option mode 'ap'
        option isolate '1'
        option key '****'
        option macfilter 'allow'
        option encryption 'psk2+ccmp'

I tried setting the country code to Default and US - United States in the access point's advanced settings. I also tried tooling with channel width and channels. Idk.

Did you edit the configuration manually? I don't radio1 here!

Anyway, for the 5 GHz channel, could you try a safer channel? something between 36 and 48?

Yes as @Hegabo said there's no radio1 block, though that should be the 2.4 radio. I'd suggest remove /etc/config/wireless and reboot, which will rebuild the config file. Then add your APs again.

It's important to set the country code to your country especially when using a DFS channel like 64. Also on DFS the radio won't start right away, it waits 60 seconds to scan for radar before bringing up the AP.

When macfilter type is 'allow' you have to list some MACs or nothing will be allowed.

Not sure if you guys are confused or I'm just misunderstanding, but no I was saying radio0 shows it's linked to Qualcomm Atheros QCA9880 802.11nac and disabled, I assume this is the 5ghz, and when I click add it's all options for a 5ghz AP.

radio1 is perfectly fine and is working for 2.4Ghz channels flawlessly.
Only the issue with radio0 which seems to be the 5Ghz radio.

No confusion. But your config file is missing some stuff. Did you manually edit it or what?

Try channel 36 for 5 GHz.

I didn't manually edit anything in that config file besides censoring out some stuff. Although I just double checked the file, my bad. It looks like some stuff didn't copy out. Will edit it above.

Also I tried channel 36 and 48 on 20mhz, 40mhz and 80mhz, and none worked

I don't know. Maybe you should try @mk24 advice of deleting the file and rebooting.

Does this have the potential of screwing up anything?

A little less agressive

wifi down
cd /etc/config
mv wireless /tmp
wifi config

reconcile the new defaulted one with the original altered config.

1 Like

Ok this worked, but I seem to be unable to go beyond channel 48 @ 80mhz before it disables itself. I don't understand why?

If you use a DFS channel (52 through 144), the radio startup will be delayed for the radar check. After 1 minute it should start, unless radar was found then it would have to start even later on a different channel.

Also in VHT80 operation there are 6 usable channels: 36-48, 52-64, 100-112, 116-128, 132-144, and 149-161. If you choose any channel within a block you get the same result that the signal covers the whole block of 4 channels.

4 Likes

I threw it on channel 144 @ vht80 and it seems to not update.
Can you elaborate on what you mean by "Unless radar was found then it would have to start even later on a different channel.". Are you saying if I put it on 144, and it doesn't update within a minute, it will automatically switch to another channel later on?

This is kinda annoying to figure out which channels are usable >.>

If a radar is detected.

Complain to your radio regulator (e.g. the FCC in the US). It's their rule/law.

1 Like

Why can't you just use a channel between 36 and 48? I don't imagine that all those channels are busy, particularly that the 5 GHz band has a relatively short range, so less interference is expected from the neighbours.

1 Like

mk24 thank you, this solved my 5Mhz radio issue! I was using 165 with VHT80, becuase in dd-wrt the bandwidth drop changed the chanel options. My default was always the last one, but in openwrt the last on is not valid for VHT80.