Archer C7 2.4ghz issues after migrating from ath79 to ar71xx

Hi Guys
I was running the optimized openwrt with fast path for the C7 (V5) which is based out of the ath79k target.
I wanted to update to the latest 19 RC2 since fast path was added officialy, however,after doing so my 2.4ghz wlan started acting up:

  • Radio name changed from QCAxxxxxx to Generic 802.1bgn (even when reverting it back)
  • Clients cannot see it for quite a few minutes after boot
  • Once they can see it ,it is very unstable(jitter of >300ms, packet loss of 10%+), speed was maximum of 5mbps. tried multiple configs.
  • I can scan other clients with it at any time.
  • Mac address is detected properly, also country code
  • Tried going back to stock, i am able to see the 2.4 briefly after boot, but then it goes away.
  • Went back to openWRT 19 RC2 (tried stable as well, no luck)
    I guess i may have screwed a firmware or something?
    Pastebin of dmesg:

IW DEV (5ghz is disabled, but works fine):

root@OpenWrt:~# iw dev
        Interface wlan1
                ifindex 8
                wdev 0x100000002
                addr <removed>
                ssid OpenWrt444
                type AP
                channel 11 (2462 MHz), width: 20 MHz, center1: 2462 MHz
                txpower 24.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcoltx-bytes tx-packets
                        0       0       0       0       0       0       0      00

lsmod | grep ath

ath                    18240  5 ath9k,ath9k_htc,ath9k_common,ath9k_hw,ath10k_core
ath10k_core           319344  1 ath10k_pci
ath10k_pci             25168  0
ath9k                  95600  0
ath9k_common           11232  2 ath9k,ath9k_htc
ath9k_htc              52976  0
ath9k_hw              343456  3 ath9k,ath9k_htc,ath9k_common
cfg80211              221232  6 ath9k,ath9k_htc,ath9k_common,ath10k_core,ath,mac80211
compat                  5888  7 ath9k,ath9k_htc,ath9k_common,ath10k_pci,ath10k_core,mac80211,cfg80211
mac80211              443008  3 ath9k,ath9k_htc,ath10k_core
usbcore               128080  4 ath9k_htc,ledtrig_usbport,ehci_platform,ehci_hcd

Screenshot of wireless tab:

(i cannot embed one more image, but here it is scanning other clients)

I also have 2.4 GHz issues since 17.04 with my Archer C7 v2 using the ar71xx. While upgrading to the new OpenWRT release 19.07 I noticed that the target ar71xx will become replaced by ath79. So I guess you're migrating in the wrong direction.

1 Like

I upgraded my Arch C7 V2 from 18.06 to 19.07 ath79 using sysupgrade -n. Didn't have issues with the wireless before or after.