Archer C7 2.4 GHz wireless dies in 24~48 hours

I have a mix, IIRC v2 and V3 use the same build, primary diff is antennas as you noted. V4 and V5 also see this same issue, so I do not think it's hardware version related. And since I see the exact same thing with MT76 units, I'm now suspecting it's an issue in mac80211 kernel code.
I was able to 'unstick' a 'frozen' (no wifi traffic flowing, could not even ping AP) AP by issuing a random iw command (e.g. iw dev ), but not sure yet if it was timing coincidence, or a byproduct of invoking a command that pokes the mac80211 stack. My AP locks every couple of days, so still waiting for the next occurrence. BTW- I've not rebooted, and all is still fine.

1 Like

And it just happened again, and an 'iw dev' got it right back. Again, not sure if timing coincidence or side-effect of running the iw utility.

How long had it been running before it froze?

I’ve had to use a cron script to reboot the AP every morning so I don’t get freeze ups.

1 Like

Less than a day ~18hrs. But I'm fairly sure a daily reboot would minimize the chances. I'm purposefully NOT rebooting to see if there is a specific mechanism to re-establish connectivity, as that might be a clue as to the root cause.


Just had an outage while typing, and in the middle of wifes company meeting...though this time it was the WAN eth in my separate router dropping, not my C7 AP! Wholly different problem, but how many times might I have mistakenly thought it was the wifi issue? Well, another issue to chase..

Just starting to look thru my old collected logs on this router box eth dropout.... and I'm starting to think I'm mostly seeing those, in recent time. (past 3-4wks) So, maybe a lot of times when the wife or someone yells "the network's down" and I check the 2.4ghz radio but not both of them, take some logs off the AP... maybe it's not the radio!

That would explain the short term drop symptom, and that it "heals itself" if I don't go fix it. If that's the case, I could say that the C7 June 4 snapshot, and it's stock ath10k selections, might have eliminated the radio problem for me. Probably too early to claim that yet. And, it may only apply to my case, where my router and C7 AP are two seperate boxes. But possibly, I've had a fixed setup on the C7, that has had external symptoms looking like the problem continued...

I've updated my separate x86 router box, (almost 138 days uptime, woohoo!!) from 19.07.1, to 19.07.03, maybe that gets me a newer rtl8169 driver for that problem. Will keep a close eye on unexpected eth1 down/ups... as well as watch for further C7 2.4ghz radio issues.


Well, 13 more days of uptime, doesn't seem that I've had a 2.4mhz dropout since, and perhaps for some time earlier than that.

Of course I have a few other settings changes, of which I don't know how much, if any, they affect this thing. I have turned off the KRACK mitigation, that's one thing, and I have the beacon set to 100ms (standard timing) but the DTIM time set to 1 (instead of 2?) So this would send a DTIM packet or whatever, with every beacon. I also run with the 802.11b compatibility off, but that's commonly used by many without fixing this issue.

And, I've been using the C7 June 4th snapshot, and that version's stock ath firmwares and drivers.
FWIW, here they are:






Also looks like there's yet a newer ath10k driver, in snapshots, here's from doing a update check today:

4.19.123+2020-04-29-3637be6f-1 » 4.19.123+2020-06-30-edfbf916-1

Oh, and I also haven't seen the mysterious eth port dropout on the x86 router box, since I bumped it up to 19.07.03.

1 Like

Been running a custom build of 19.07.3 (running Archer C7 V2 as an AP) and I'm up to 10 days runtime without a reboot. It seems that 19.07.3 has been a rock solid build for me.

Note that I'm not using stock firmware and drivers for ath10k:






Lucky you... ;-(

I take it you haven't had much luck?

Unfortunately not, I'm now on trunk with kernel version 5 and it seems no difference for me - still getting 2.4 GHz dropouts. I will probably soon trow my C7v2 away as there is not interest to get it fixed ;-(

After reading about this issue so long just would like to say that at latest Gargoyle version my Archer C7 v2 is rock solid for both 5gz and 2.4gz band for a looooong time.
Using openwrt at my TL-WA801ND only

Hope one day it will be fixed so i can switch back to openwrt with my Archer C7 v2


Just a feeling, but some weeks ago I decided to reduce running SSIDs on the same Archer AP from 8 to 3. Feels like this also contributes to stability, only one dropout under heavy load so far.

Could you post the ath9k/10k drivers and firmware versions that Gargoyle uses?

1 Like

Sorry for delay
The version that i use is 1.12 and here is the link for downloading it

In order to really test whether 2.4 is stable: Configure it as AP, connect multiple WiFi devices and run iperf3 on all towards wired iperf3 server. I have tried many many different combinations of both ath9 and ath10 drivers and 2.4 always folded eventually.

It seems that it will do that with multiple devices connected.

Hi ,

I have an old Archer c7 v2 (EU) which I have been using for years.

I have read through lots of posts/threads and it seems that the issue for openwrt and wireless still exist ?
Interested in gargoyle as you mentioned, is it really error free and performance is just as good/maybe better than stock ?

Yes it is, i bought Archer C7 V2 eu at 2016 and was experiment with openwrt and from that days i had problems with stability. After someone recommended gargoyle and i try, science then i am with gargoyle (if remember well it was 1.8 version when i first switched and still using it as now its 1.12)
As far as i read issues with openwrt i will stay there.

Great. This is the first time I will be installing custom firmware for a router. I will use the version you mentioned. Apart from more features, securtiy updates and nicer interface - How is the performance with gargoyle ? Is t better/ worse ?

I have read that on openwrt, there are issues with hardware nat, lan speeds much slower and wifi issues. None of that on gargoyle ?

One last thing, is it easy to revert back to stock from gargoyle?

Many Thanks

If you are at stock firmware then you cannot install the link that i give you, this link is valid only for upgrade gargoyle -> gargoyle and openwrt -> gargoyle
For Factory (OEM) firmware is different file

Better make a research if you can switch from OEM firmware to openwrt/gargoyle before doing it because you can brick it.
The most important is if the current OEM firmware version support the update/upgrade direct from GUI with the OpenWRT/Gargoyle firmware file otherwise maybe you will need to follow some steps little advanced
If you upgrade from OEM firmware to OpenWRT or Gargoyle then to switch between OpenWRT and Gargoyle is very easy but to go back to OEM its little tricky and usually its not recommended

About gargoyle i would like to mention that Gargoyle is based on OpenWRT and actually its OpenWRT with Gargoyle User Interface (but the v1.12 of gargoyle which is the latest correspond to v18.06 if remember well of OpenWRT)
One thing that Gargoyle is superior to OpenWRT is QOS build in. I spend some days with trial and error and following some guide on forum and manage to set it up so good so when i make test by downloading with torrent from laptop, watching youtube on smartphone and playing an MMO game at my Console SIMULTANEUSLY surprisingly i didnt had any lag at that point so i forget that i was making test while i was plying with my Console (XBOX ONE X) :stuck_out_tongue:
About WiFi for sure i can confirm both 2.4 and 5 Gz are rock solid. About hardware nat/lan speed i didnt notice anything strange with my usage so i am satisfy

Here a link that maybe help you

Have in you mind that as i mentioned before, Gargoyle and OpenWRT are same, so if you manage to install for first time one of their firmware then you can switch easily between them with Sysupgrade Firmware

The only thing I can't see in Gargoyle is VLAN tagging. My network is separated by VLANS and I couldn't see anywhere in the Gargoyle GUI where I could configure any VLANS.

I tried connecting to the router via SSH but couldn't connect - I wonder if I'm missing a setting to allow connection.