Archer C7 2.4 GHz wireless dies in 24~48 hours

It has now been online for 4 days and subjected to load that usually brings it down within 24 hours. It definitely works, despite it should not. Both 5GHz and 2.4GHz rock solid. Perhaps someone can do some more intricate debbuging on why 5G firmware bugs 2.4G radio?

This is my "magic mix" for fully functioning Archer C7 v2 with 19.071 image:

1 Like

Correction: it worked....until it didn't.

2.4GHz stopped responding today. Failure mode was slightly different: some of associated stations were still associated but could not send anything. I tried connecting a phone to 2.4GHz, it would associate but not surf. Two hours later it could connect and surf.

Anyway, 2.4GHz is still dodgy on Archer C7 v2 and replacing ath10k stuff seems not to fix the issue!

19.07.2, ct-htt firmware for ath10k, >100-hr uptime, 2.4GHz still running...

1 Like

I've been running OpenWrt 19.07.2 since it came out and I switched to this the same day. Absolutely no problems since that installation.

The issues manifest themselves when you have multiple connections. I have 6 clients, 1Gb fiber connection and after few days, it will bring 2.4GHz down. If you use low bandwidth single client and have ADSL you will unlikely experience same kind of issues.

Try completely shutting down 5 GHz and test heavy use on 2.4 only. This could differentiate if there really is a relation to the 5 GHz. It could be that 2.4 itself has a problem.

@Gruntruck My experience has been the same. Two low traffic IoT clients chug along for a long time. Introduce one streaming and/or gaming machine and it goes south fast. BTW This happens only on wireless. Ethernet switch works just fine on any load.

1 Like

@mk24. I was using in that mode when it failed all the time. 5 Ghz was not configured at all.

Now I am using both 2.4GHz and 5 GHz. It seems to be working for 24 hours and have a cron job that reboot the router every night.

Hello,

I have the same problem with 2.4GHz on Archer C7 v2.
After upgrading my uplink from 100 Mbit/s to 1 GB/s the 2.4 Wifi dies a lot more frequently...
5GHz is still running fine.

When the error occurs, the following message is logged in syslog:

Sun Mar 29 14:13:06 2020 kern.err kernel: [ 4218.030163] ath: phy1: Unable to reset channel, reset status -5
Sun Mar 29 14:17:27 2020 kern.err kernel: [ 4478.945333] ath: phy1: Unable to reset channel, reset status -5

I was able to reactivate 2.4GHz when executing "wifi" command from SSH console.
Another way is to disable and then reenable 2.4GHz wifi with Luci webinterface.

At the moment I use OpenWrt 19.07.2 r10947-65030d81f3 with:

ath10k-firmware-qca988x, 2019-10-03-d622d160-1
kmod-ath, 4.14.171+4.19.98-1-1
kmod-ath10k, 4.14.171+4.19.98-1-1
kmod-ath9k, 4.14.171+4.19.98-1-1
kmod-ath9k-common, 4.14.171+4.19.98-1-1
kmod-phy-ath79-usb, 4.14.171-1

We should use a small script, that reenables 2.4GHz wifi after this error message.
I have used a modified version of: Ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
Let's see if it helps :wink:

Uwe

1 Like

For some reasons my 2.4GHz is still running after 9 days.... The last configuration parameter I remember changing was disabling legacy rate.

Cheers.

Hello,

after another 2.4GHz shutdown today I had no message in syslog or kernellog :frowning_face:

Now I use the following cron script to detect loss of all 2.4GHz clients.
If no client is visible (should not happen), the "wifi" command reconfigures 2.4GHz wifi.

#!/bin/sh
sleep 60
grep -q 0 /sys/kernel/debug/ieee80211/phy1/netdev:wlan1/num_mcast_sta
if [ "$?" -eq "0" ]; then
    sleep 10
    /sbin/wifi
fi

Edit:
The script works! I had another fail and it was catched and recovered by the script. :stuck_out_tongue:

Uwe

2 Likes

Its a shame we need to rely on scripts on Archer C7. This router was touted as a star for using openwrt. It seems that openwrt release over the years have become worse.

It is not OpenWRT per se that is failing, it is ath9k 2.4GHz firmware blob that is buggy. I now only use 5GHz on all my C7 dumb-AP's and it is rock solid. It seems that whatever 2.4GHz blob that is "baked" into distro is buggy. Perhaps we should try with some very old one?

2.4GHz usually kinda works, as long as you do not "load" it with many devices and/or high throughput. This was the issue with Archer C2's as well, so I got rid of those.

If the old firmware worked well, why are we updating to new ones which is giving so many issues? The QA/QC is clearly broken on Openwrt's part.

Old firmware didn't work for me, nor htt version of ath10k-firmware-qca988x-ct-htt, now I'm testing smallbuffers - kmod-ath10k-ct-smallbuffers. Btw I'm on latest trunk. Also turning off "Disassociate On Low Acknowledgement" didn't work for me.

I was never able to make 2.4G work well on OpenWRT C7 distro regardless of version. On the other hand, 5GHz always worked flawlessly. (Same with Archer C2). As far as I understand, ath9k firmware blob bundled with OpenWRT is somewhat "closed source" so only thing you can do is roll with factory blob and hope for the best. Unfortunately, something is not playing nice with OpenWRT.

Also, this was never actualized enough as 2.4G "mostly" works. Bug is unlikely to be triggered by someone with two devices sitting on ADSL. But if you have >100Mbit WAN and many devices, chances are you will trigger it. I just use C7's as 5GHz AP's/edge switches and that's where they excel.

After switching 2.4 GHz from 40MHz Bandwidth to 20MHz, it looks a lot more stable! - Until now I had no issues after this change.

Uwe

2 Likes

I can confirm as well...since then no issues at all.

Hello again,

limiting 2.4GHz to 20MHz bandwidth makes my device rock stable.

I have two 2.4GHz networks with permanent traffic and an additional (not shown) 5GHz network:

Now the developers must find the reason for this :wink:

Uwe

Is that with ath10k-firmware-qca988x-ct-htt and kmod-ath10k-ct-smallbuffers? Or is that with just changing the bandwidth to 20MHz?