Archer C6v2 5Ghz radio randomly stopped working

I initially posted this three days ago,started experimenting to brick it and then reflashed and it was working fine intill i was having particularly bad speed and the 5Ghz SSID didnt even really give internet, so i restarted and lo and behold the same issue, the logs are from the old install but id assume they wouldnt have change much since the issue is the same. Please help

ubus call system board:

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.134",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link Archer C6 v2 (EU/RU/JP)",
        "board_name": "tplink,archer-c6-v2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0",
                "revision": "r23497-6637af95aa",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05.0 r23497-6637af95aa"
        }
}

cat /etc/config/network:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd56:e408:86f3::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.0.0.100'
        option device 'br-lan'

config interface 'wan'
        option proto 'pppoe'
        option password 'star123'
        option ipv6 'auto'
        option username '*pppoe-usn*'
        option device 'eth0.2'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'
        option auto '0'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

Note: pppoe-usn has been changed here for privacy reasons

cat /etc/config/wireless:

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option cell_density '0'
        option country 'IN'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT40'
        option channel '6'
        option country 'IN'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key '*password*'
        option ssid '*SSID*_2.4Ghz'
        option encryption 'psk2'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid '*SSID*'
        option encryption 'psk2'
        option key '*password*'
        option network 'lan'

Note: SSID and password have been changed here for privacy reasons

cat /etc/config/dhcp:

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option mac '*MAC Addr*
        option duid '*is this sensative?*'
        option ip '10.0.0.10'
        option name 'MyPrecious'
        option dns '1'

config host
        option mac '*MAC Addr*'
        option duid '*is this sensative?*'
        option ip '10.0.0.12'
        option name 'MAGxel7A'
        option dns '1'

config host
        option mac '*MAC Addr*'
        option dns '1'
        option name 'MAGPi'
        option duid '*is this sensative?*'
        option ip '10.0.0.11'

Note: is this sensative? and MAC Addr have been changed here for privacy reasons

cat /etc/config/firewall:

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config redirect
        option dest_port '22'
        option src 'wan'
        option name 'MAGPi SSH Fwd'
        option src_dport '2200'
        option target 'DNAT'
        option dest_ip '10.0.0.11'
        list proto 'tcp'
        list proto 'udp'
        option dest 'lan'
        option enabled '0'

config redirect
        option dest_port '9000'
        option src 'wan'
        option name 'Portainer MAGPi'
        option src_dport '9000'
        option target 'DNAT'
        option dest_ip '10.0.0.11'
        option dest 'lan'
        option enabled '0'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'SSH'
        option src 'wan'
        option src_dport '5555'
        option dest_ip '10.0.0.11'
        option dest_port '22'
        option enabled '0'

You can see the remnants of me trying to set up port forwarding here, i never got it running and couldn't even ping my IP address but i thought it might be an ISP thing, while instructions of running a traceroute don't indicate CGNAT i might post that as a separate topic after confirming with my ISP (I'm especially skeptical because i couldn't get port forwarding running on my default TP-Link software either before switching) however if you can see what the issue is from this and think it's a configuration issue, ill be eternally grateful. However, right now the priority is understanding why my 5Ghz antenna isn't working.

I thought I'd also note when i try to navigate to https://10.0.0.100/cgi-bin/luci/admin/network/wireless i get:

404 Not Found
Sorry, the object you requested was not found.

No page is registered at '/admin/network/wireless'. If this url belongs to an extension, make sure it is properly installed. If the extension was recently installed, try removing the /tmp/luci-indexcache file.

Unable to dispatch: /cgi-bin/luci/admin/network/wireless

Thank you