Archer C60 v3 - is possible to install OpenWrt firmware?

Download the zip file, unzip it, install the -factory.bin file in the TP-Link webinterface like every other Archer C60. See wiki for instructions.

1 Like

I successfully installed yesterday night, it worked perfectly! Nice job. I then made the sysupgrade. I am just not sure how should I apply the patch. I have to follow this right ? (

No, the patch is only for developers who want wo build OpenWrt by themselfes. If you just want to use the router thats it.

@JamesT42 I downloaded and installed this firmware & it is working fine. Thanks for building this for v3. Just wondering why the firmware version is 18.06.4 while the latest available is 18.06.5 ? Will you be building 18.06.5 as well ?

Also, do I still have to install the sysupgrade.bin after installing the factory.bin image ?

Thanks again for building this :+1::+1:

No the sysupgrade is for upgrading / downgrading OpenWrt afterwards. For example to 18.06.5 after I finish compiling.

Download 18.06.5 with ath10k for Archer C60 V3

New build with 18.06.5.

1 Like

@JamesT42 Would be great if you could prep a patch for ath79 (ar71xx won't be getting any updates anymore) and file that for inclusion.

I've checked your patch and it looks like a quick (but working) hack, hardware seems very similar though judging from how you added support. Shouldn't be too difficult then.

I'm no developer. I just copied everything I could find from the V2 version and found the change for the led by trial and error. I have no experience with the ath79 stuff. I was hoping someone else with experience could do that.

1 Like

Its working good. Can I proceed to normal update process to keep it up to date?

I do own a TPLINK-1350-C60-V3 router. Openwrt works fine except connecting more than 2 devices to the 5Ghz access point crashes it. The 2.4G and the Ethernet works well though. Also is there a way to revert back to the stock firmware? I tried TFTP and web recovery but i see no success. It would be helpful if you could educate me on how to revert back to the stock firmware.

I've quickly put together a patch prototype for ath79:

This missed the kernel magic hack and the LED adjustment, as the mach files in the patch mix v2 and v3. Please clearly state which LEDs are available and which gpio they use.

This is just based on the scarce information provided here so far. To get it merged, much more details about the device will be needed.

I have been given such a device and will try to build working support for it.

From the bootlog above, it looks like it's really a clone of the v2 ...

1 Like

Supporting the device seems straightforward, but TFTP does not work for me.

I do not have a serial console connected, but I see that the file is downloaded successfully and then the device immediately restarts into the old FW.

Has anyone here tried TFTP so far?

(Probably noob question)
Is there a good reason archer c60 doesn't exist there? Also my doubt is if I can use the v2 file, but I suspect not.

Before that I tried via this link downloading and flashing with the Firmware OpenWrt snapshot Upgrade URL and was surprised with this error:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

My current version: 18.06

Any suggestions?

Thanks in advance

Hi! The V3 stuff simply came to late to be in 19.07. Do not use the V2 Image. You can use snapshots. Be aware that you have to installl Luci by yourself in snapshots. See the wiki for that. The other problem is described here.


The snapshot image should be working. However, maybe the hacked 18.06 is the source of the problem? I will try the snapshot on my device later to make sure.

You are lucky, as I've built a backport for downstream anyway and therefore merged it into 19.07 as well (which typically would not have happened for a device supported after the branch).

C60 v3 should be built for the next point release. Or build it yourself if you can't wait for it :slight_smile:

But be aware that for me TFTP didn't work with vendor firmware image, so if you flash OpenWrt you might have to stick to it.

Actually, I'd be very interested if someone here could try to reproduce that (and thus prove that it's not me doing it wrong). TFTP with stock image is not working, but TFTP with OpenWrt factory image works fine.

You aren't alone @adrianschmutzler. TFTP with stock image didn't work on my C60 v3 either. I had the snapshot image on but couldn't get the internet setup (too long process). So I went back to the 18.06.5 image that @JamesT42 built.

I believe we need a stripped version of the v3 stock firmware in order to get it working again. Can someone help ?