Archer C60 v3 Atheros QCA9886 5GHz ath10k issues

I've got a TP-Link Archer C60 v3. I installed OpenWrt 19.07.7
Everything was fine but the radio0 (Atheros QCA9886) stopped working (why?)
I searched the forum and there are many users with 5GHz problems with ath10k module.

the 5GHz channel is not seen by any of my devices (it worked at first)

As suggested, I set Country code to driver default, 00 world, US, ... no success
I tried different channels auto-36-40, (or even 149) with 20MHz or 40MHz width... no success

I changed the kmod-ath10k-ct & ath10k-firmware-qca9888-ct with the one not optimized by Candela Technologies. or the "-smallbuffers" version ... no success

Are there people with same difficulties and suggestions?

Thanks! Openwrt is great!

Did you solve your problem ? I have an C60v3 with stock firmware yet, I plan to install OpenWRT. Searching for compatibility I found information about 5ghz support of v1:

V1 and V3 has the same chipset:

If you read this commit, says there are firmware problems with ath10k:;a=commit;h=e39dc8d823c86559eedbbdcee5f5c14b827fed0f

I don't know if anything changed since then.

Looks like 5ghz is supported by ath79 ?;a=commit;h=646d95c374072598fab9e949ef4425177c5c7960