Archer C60 v2 seems to be freezing when torrenting and sometimes randomly

My TP-LINK Archer C60 v2 seems to be "freezing" randomly and recently, when torrenting. My router always had this problem since I installed OpenWrt on it a year or so ago when I bought it.

It started by randomly "freezing" with a delay of a few days (and sometimes longer), when it freezes, the lights keep blinking (similar to how they would be when transmitting data over WiFi), but I could not access the internet or the LuCI web interface. And also I could not disconnect and reconnect as it will not connect once I disconnect, this seems to indicate some issue with the wireless software.

And I discovered only yesterday that, it also happens when I download a torrent. It never happened before, and I have downloaded plenty of torrents since I installed OpenWrt, it has only been happening recently.

Any clues as to what might be the issue? Thanks for the help in advance!

1 Like

Which OpenWrt release do you have installed?
Any changes recently, like new firmware image flashed, new package installed, ...?
Any new wireless devices (smartphones, TV, ...) connecting to the C60 since this issue occured?

Can you please provide logs?

My first guess would be memory exhaustion.

1 Like

Thanks for the fast response :slight_smile:

OpenWrt 18.06.4 r7808-ef686b7292

No, this issue has been present since my first installation of OpenWrt in the router.

Nope, no new devices have been added recently.

Yes, which ones would you like to see? I assume the usual system logs expire after a restart (which is the only way to fix the issue)

1 Like

Have the same issue with Linksys EA-8500 no matter if i use openwrt or DDwrt, the only that works better in openwrt is that here it reboots after freeze instead of hunging up in DDwrt...latest firmware versions have fixed it but its still happenening randomly, by the way i am not using Router build in torrent client, i have a linux system with samba and transmission only for torrenting.

Can you still access Luci over a cable once the hang occurs?

I have not tried. But I can the next time it happens. It will be good to know which logs are essential... maybe there is a wiki page which shows how to get the logs :slight_smile:

When the freeze happens is luci dead? What about ssh?

1 Like

on openwrt 18 it was totally dead, now it just reboot! i haven't noticed any permanent hung up which needed power cycle lately!

Thanks for the link to the doc about log essentials :slight_smile:

I will check those two factors that you mentioned (and any others which catch my eye) and report back as soon as I encounter the issue again.

1 Like

If the unit is frozen you'll want to have a live feed of the output I would think.

I am still not sure if it is the entire unit is freezing or only the wireless aspect of it. But I will find out after connecting to it directly :slight_smile:

I will try to get the live feed of the output in case the entire unit is freezing.

The issue happened again a few days ago, it happened consequently 2 or 3 times on that day. I was not able connect directly to the router as I was busy with work at that time, but I did try an interesting experiment which resolved the issue:

Instead of turning of the router and turning it on manually, I turned off the radio and turned it manually using the little button I have in my router, that fixed the issue with WiFi connectivity.

Any thoughts on what might have been the issue taking the new information into consideration?

Edit: Just to make things more clear, I was not downloading any torrents or was doing any heavy internet activity when it happened, so the problem may not be entirely dependent on the load. I was doing the casual browsing while working, which I do almost everyday and it usually never happens at those times.

I upgraded to version 19.07.2 a couple of weeks ago and and since then I have downloaded some huge torrents (some 200GB+), and I am happy to report that my router never had a hiccup ever since :slight_smile:

So it looks like the version update fixed something which was causing the wireless radio to stop working.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I already tried marking my post as the solution, but I noticed that it activates the auto-close timer, I would like to hear any technical details about why this might have been solved etc., so I would like to keep the topic open, if that is okay.

No problem to keep this topic open, but my expectation is that you won't easily get the "why".

That will be tricky without any logs from your 18.06.4 installation...