Archer C60 (us) v3 1.2.0

Hi!
I am trying to flags my brand new tp link Archer C60 v3 us version build 1.2.0 with no success
Got the .bin file renamed it to tp_recovery.bin and tried to use the GUI to update the firmware but I get "Invalid file type"
Then I tried with TFTP flashing, both in Ubuntu and windows, only on windows I saw that the file was uploaded to the router but then NOTHING!
No flashing lights nor special lights patterns.

And yes I make sure I set up my IP to 192.168.0.66 255.255.255.0 192.168.0.1
Disabled the wifi, tried different lan ports but still the same behavior.

Not sure what I am doing wrong and if anybody has successfully flash this router.

Any suggestions will be appreciated

Ps1- This is my very first attempt with openwrt so be patient with me :slight_smile:

Ok, got it now
Had to download a FACTORY .bin image not a kernel one even when there is a note in the website implying that a kernel will be ok for a first time flash.
Gotta say, Archer C60 is a very bad router internal storage is a joke!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.