Archer C6 - Flaky 5GHz Wifi

Hi Everyone :wave:

Following the TP-Link Archer C6v2 (EU) Wiki Page, I flashed the 22.03.5 firmware successfully and was able to go about my business as usual. I found the Wifi extremely flakey, especially on 5GHz, randomly dropping connection and subpar speeds.

I then tried replacing the “kmod-ath10k-ct” and “ath10k-firmware-qca9888-ct” packages with “kmod-ath10k” and “ath10k-firmware-qca9888” as recommended in the Wiki, and the 5GHz card disappeared altogether. The interface becomes "generic", then disappears after rm -rf /etc/config/wireless and rebooting. Even installing the "ct" drivers again does not solve the problem. Only a complete reset does.

dmesg output after installing the "ct" driver again

[   15.905399] ath10k 5.15 driver, optimized for CT firmware, probing pci device: 0x56.
[   15.915387] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
[   15.922213] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   17.274870] ath10k_pci 0000:00:00.0: qca9888 hw2.0 target 0x01000000 chip_id 0x00000000 sub 0000:0000
[   17.284440] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   17.303702] ath10k_pci 0000:00:00.0: firmware ver 10.4b-ct-9888-fH-13-5ae337bb1 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,htt-mgt-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT,wmi-bcn-rc-CT crc32 9a038867
[   17.643425] ath10k_pci 0000:00:00.0: Loading BDF type 0
[   17.695594] ath10k_pci 0000:00:00.0: failed to fetch board data for bus=pci,bmi-chip-id=0,bmi-board-id=20 from ath10k/QCA9888/hw2.0/board-2.bin
[   18.312968] ath10k_pci 0000:00:00.0: failed to fetch board-2.bin or board.bin from ath10k/QCA9888/hw2.0
[   18.322721] ath10k_pci 0000:00:00.0: failed to fetch board file: -12
[   18.348911] ath10k_pci 0000:00:00.0: could not probe fw (-12)

dmesg after installing the "non-ct" drivers:

[   15.501643] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
[   15.508434] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   17.819637] ath10k_pci 0000:00:00.0: Failed to find firmware-N.bin (N between 2 and 6) from ath10k/QCA9888/hw2.0: -12
[   17.830651] ath10k_pci 0000:00:00.0: could not fetch firmware files (-12)
[   17.837654] ath10k_pci 0000:00:00.0: could not probe fw (-12)

Noting that the Archer C6v2 has the QCA9886 chip, not the QCA9888

Any help would be appreciated

Update

The problem has been solved by building a custom image with the non-ct modules and flashing the image using tftp

Build Link: https://firmware-selector.openwrt.org/?version=22.03.5&target=ath79%2Fgeneric&id=tplink_archer-c6-v2
Build Packages:

ath10k-firmware-qca9888 base-files busybox ca-bundle dnsmasq dropbear firewall4 fstools kmod-ath10k kmod-ath9k kmod-gpio-button-hotplug kmod-nft-offload libc libgcc libustream-wolfssl logd mtd netifd nftables odhcp6c odhcpd-ipv6only opkg ppp ppp-mod-pppoe procd procd-seccomp procd-ujail swconfig uboot-envtools uci uclient-fetch urandom-seed urngd wpad-basic-wolfssl openssh-sftp-server openssh-sftp-client luci luci-app-firewall luci-app-opkg luci-base luci-lib-base luci-lib-ip luci-lib-jsonc luci-lib-nixio luci-mod-admin-full luci-mod-network luci-mod-status luci-mod-system luci-proto-ipv6 luci-proto-ppp luci-ssl luci-theme-bootstrap liblucihttp-lua liblucihttp0 rpcd-mod-luci

Once the image was flashed using tftp, the QCA9886 chipset was picked up correctly and the 5GHz radio was operational and able to scan for networks using the non-ct drivers.

Long term testing is yet to be done

Note: I was not able to edit the original post or amend [SOLVED] to the post title.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.