Archer C6 Dumb AP Slow

Continuation of this topic OpenWRT 23.05.3 N95 slow NICs - #13 by Exio0 @frollic @LilRedDog

Please connect to your OpenWrt device (TP-Link) using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

And please run the speediest using the TP-Link wired to the PC.

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.10.176",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link Archer C6 v2 (EU/RU/JP)",
        "board_name": "tplink,archer-c6-v2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.5",
                "revision": "r20134-5f15225c1e",
                "target": "ath79/generic",
                "description": "OpenWrt 22.03.5 r20134-5f15225c1e"
        }
}
root@OpenWrt:~#

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd15:41f3:262b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.2'
        option gateway '192.168.2.1'
        list dns '192.168.2.1'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '20'
        option ports '0t 5t 1t'

config route
        option interface 'lan'
        option target '192.168.2.226/24'
        option gateway '192.168.2.1'
        option disabled '1'

root@OpenWrt:~#

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option band '5g'
        option htmode 'VHT80'
        option channel 'auto'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'redacted-PLUS-sxYU'
        option encryption 'psk2'
        option key 'redacted'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option band '2g'
        option htmode 'HT20'
        option channel 'auto'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'redacted-sxYU'
        option encryption 'psk2'
        option key 'redacted'

root@OpenWrt:~#

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~#

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option synflood_protect '1'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'REJECT'
        option forward 'REJECT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~#

image

okay, we're getting closer

Okay, that is not a dumb AP and I'm not good at fixing CLI so someone will need to figure out why that configuration is affecting wi-fi but not lan traffic.

Summary of configuration for a Wireless AP:

  1. The wireless AP is connected LAN-to-LAN to the main router by some means e.g. ethernet cable, 802.11s mesh, etc.

  2. The wireless AP bridges its SSID wireless interface onto its LAN bridge interface. Wireless traffic on the wireless AP goes to its bridge LAN interface, then to the main router.

  3. The wireless AP bridge LAN may have either a static or DHCP address on the same subnet as the main router bridge LAN interface.

  4. The wireless AP gateway IP address is set to the address of the main router, either in the configuration or by DHCP.

  5. The wireless AP does not provide DHCP service, DNS resolution, or a firewall.

start by setting a country for your radios, and a chan, instead of auto.

1 Like

Should i delete all the rules/zones on that AP?

Done: Country Spain and no channels in auto, 153 for 5Ghz and 11 for 2.4Ghz. Nothing changes on the speed

No, you should wait for someone that understands what you have done better than me.

1 Like

if the dumbap config is correct, and you're not using the wan port, the traffic isn't touching the firewall.

repost your /etc/config/wireless

right :man_facepalming:

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option country 'ES'
        option channel '153'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'redacted-PLUS-sxYU'
        option encryption 'psk2'
        option key 'redacted'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'ES'
        option channel '11'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'redacted-sxYU'
        option encryption 'psk2'
        option key 'redacted'

root@OpenWrt:~#

and what's the wireless client ?

phone ?
computer ?

a bunch; repeater, phones, PCs...

But im doing the tests with a Laptop

and what's the wireless card on the laptop ?

do you get the same throughput using a phone ?

Intel(R) Dual Band Wireless-AC 3168

More or less, yes, is the same

This has improved the speed but it is not close to what it should have

In Spain channel 153 is a 20MHz channel.

I have tried a few based on your answer (even looking at which is the best channel for Spain) and the speed remains the same :frowning:

Just trying; I cannot find anything wrong with the wireless config.

It's okay, I thank you very much.

Did you read this on your router's OpenWRT page?

Warning The 5 GHz radio / Qualcomm Atheros QCA9886 support seems to be buggy in some cases.

Some users report much improved long-term stability with 5 GHz by using the closed-source ath10k firmware instead of the open-source ath10k-ct firmware. To do this remove the packages “kmod-ath10k-ct” and “ath10k-firmware-qca9888-ct” and instead install “kmod-ath10k” and “ath10k-firmware-qca9888”.

1 Like

While there may be functional differences (as in different kinds of bugs) with ath10k and ath10k-ct, both are equally closed source.

Doing this i have notice i dont have enough free space... i did a backup before the changes and restoring it, now i dont have LuCI, dont know why:

I still have SSH access.

I could only uninstall “kmod-ath10k-ct” and “ath10k-firmware-qca9888-ct” and install only kmod-ath10k, for "ath10k-firmware-qca9888" I don't have space, but I'm surprised because I have uninstalled the first two...

Could you also tell me which packages should i remove? (not necessary ones)