Archer C59 LAN1 Issue

Hi all,

as described in:
https://git.lede-project.org/?p=source.git;a=commit;h=e39dc8d823c86559eedbbdcee5f5c14b827fed0f

there is no support for LAN1 for Archer C59, but i don't know why after some tests it started working for me.

The story:
It was not working after flashing the router with the lede firmware.
I tried to configure my network for my needs... and it started working.

Here my network config:

[CODE]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd30:d583:d347::/48'
config interface 'lan'
option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option ipaddr '192.168.90.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth0 eth1.2'
option type 'bridge'
option proto 'dhcp'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 3 2'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 4 1'[/CODE]

I can ping the router thought the LAN1 at the 192.168.90.1 and i can access the router as expected.

Maybe this can help to understand the problem.

Hope this can help somebody.
Have a nice day

Issue with LAN port is fixed by https://github.com/lede-project/source/pull/846