Archer C50 v4 Mac80211 Loses Internet Access after 20'+ Away from Router But Maintains Connection

Thank you for the patch. Once the patch is merged, is there any possibility of the pre built image for c50 v4 ?

To build your OpenWrt image including the patched driver, download the patch from https://github.com/openwrt/mt76/pull/442.patch and copy it to the directory packages/kernel/mt76/patches of your OpenWrt source.
Then rebuild the image.

4 Likes

Eventually worked out how to build a new version as above, and is now working perfectly for me :slight_smile:

Wonderful to hear @VintageRain. I haven’t found the time to apply it myself. Hope it will make it in the next release so others avoid the issue.

Would you mind sharing your compiled patched version? I've been trying all day without succes. It'd be very nice of you or anyone who can share a patched version of the kmod or the firmware.

Yep I can do that... I'll share a link. Bear in mind this is for the v4, is based on 19.07.4 and I can't accept any responsibility etc etc :joy: But I wish you luck! I just uploaded this using the LuCI web portal..
https://mega.nz/file/ZEwz2IhB#S-nb5UfDJRUUyuEIRvh9MfPj4pUTlXAV_RblBlJezKM

5 Likes

Thank you very much. You've really made my day :heart::heart: It worked well as expected for my Archer C50 v4 :heart:

1 Like

serious problem also with my c50v4 devices...
note though, e.g. netgear r6120 is NOT affected although it uses the same mediatek chip.

Thanks for creating a binary :). Do you have to delete your old configuration to install this patch? I installed the patch but it still says that radio0 is "Generic 802.11bgn" and I still get 1Mb speeds. I was able to confirm the hardware ID for mine is 0x7600.

dd if=/dev/mtd9 of=output.binary
hexdump -C /dev/output.binary
outputs:
00000000 00 76 00 02 00 0c 43 e1 76 30 00 00 00 00 00 00 |.v....C.v0......|

Also big thanks to dtrautmann!

1 Like

I built a snapshot last night. In addition to the patch, it has zram-swap, zram-tmp, adblock, ddns, ipv6, and unbound built in. I removed any PPPoE packages, but there may be enough space to install using opkg.

Link.

Thanks for sharing. I've yet to have any luck applying VintageRain's upgrade file.
Is your an image or upgrade file? Can it be used to flash OEM -> Openwrt or do i need to be on Openwrt first then use it as an upgrade?

It's a sysupgrade. Follow the directions here to flash from OEM firmware to openwrt, then apply this as an upgrade.

Thanks @ronasimi for pointing me back to the wiki. The instruction regarding building your own image has changed since i last visited. There are some additional terminal lines added. I'll give it a go again later this evening.

The relevant section of the wiki page:

If you do not want to create your own OpenWRT install image, pre-built albeit older 19.07 snapshot images are available. The images were built by the forum user bill888 and announced here.

Download and extract the contents of the zip file in this dropbox folder. The file contains Open Wrt image files, an image file to revert from OpenWrt to the TPlink stock firmware and detailed instructions for installation via Web GUI and TFTP.

To install using TPlink Web GUI:

Log into the TPlink's stock firmware Web GUI at 192.168.0.1;
Flash the router with 'boot.bin';
After the router restarts, log into LuCI at 192.168.1.1;
Download the latest stable release: tplink_C50-v4-squashfs-sysupgrade.bin (linked above, in the “Downloads” section). Use LuCI to install the sysupgrade file, untick the 'Keep Settings' check box.

Works great on my Archer C50 v4 Thanks !!

it works guys on c50 v4 thank you for this great work
god bless you all :heart:

Works great on my C50 V4.20 (CA) :slight_smile:
Thank you for your build !

1 Like

Hi @VintageRain. Nice that you managed to build a version with the correct driver. I tried but unfortunately I was unable to apply the patch in the build process.

I followed the recommendation of @dtrautmann, that is, I put the patch inside the packages/kernel/mt76/patches directory and simply recompiled it. I think there are some more steps to properly apply the patch.

If anyone can help, I am immensely grateful.

1 Like

I too would be grateful to see a mini tutorial. I've done custom FW builds using the imagebuilder file that are downloadable via https://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt76x8/ . But i've never needed to apply patches before. I tried the compiling method but was overwhelmed and ultimately unsuccessful.

Based on your screenshot, the patch isn't at the good directory? You put it on Patches-5.4 folder
I built an image (v19.7.04 not from master) this morning and the patch applied to the m76 kernel. You have to put on the good folder provided by drautmann.

If someone have the same problem, I had some dropouts when streaming from Netflix/Disney (Chromecast)

I reverted a commit on mtk_soc_eth.c (just wrote back from the older blob)