Archer C50 v4 Mac80211 Loses Internet Access after 20'+ Away from Router But Maintains Connection

The wiki does mention this for the v4. It references this forum thread.

1 Like

i see it now ... my eyes has low signal too :sweat_smile:
is there a chance to fix this problem ? i read c50 v3 has the same problem wich is solved by flashing 18.06.8 ... I think this hardware with stable release can do great performance

Minor and unimportant update:
Bought EU v4.20 version and the 2.4GHz problem persists with latest build.
Too bad :frowning:

1 Like

same thing here i bought this device too i didn't realize the notification about low signal in the wiki ...

same thing here

I've got 6 of these Archer C50 v4.{0,1,2} devices, 2 of them working fine with OpenWrt, the others have the low signal problem with identical firmware.

After digging into the problem I found there is a difference in the contents of the eeprom partition /dev/mtd9. The first two bytes in the eeprom are the chip id. The working devices have 0x7628 there, whereas the non-working devices have 0x7600 there. This chip id gets checked by the function mt7603_check_eeprom() which leads the driver to ignore the contents of the eeprom partition and load default values from otp.

After patching the driver to also accept 0x7600 as valid chip id, all of my devices are working fine.

What is the right way to submit a patch for mt76 driver?


Perhaps report your findings in original bug report 2781, and hope a developer will pick it up and submit the fix for you:

1 Like

Please submit that patch, the 2.4 GHz is terrible.

1 Like

I submitted a pull request on but I'm not sure I did it correctly. Could you have a look/comment on the pull request?

1 Like

@dtrautmann Would you mind taking some more time outline the steps to you took to patch the driver so I and other can duplicate your work? Or provide instruction on how to use the patched driver?

Thank You.

1 Like

Thank you for the patch. Once the patch is merged, is there any possibility of the pre built image for c50 v4 ?

To build your OpenWrt image including the patched driver, download the patch from and copy it to the directory packages/kernel/mt76/patches of your OpenWrt source.
Then rebuild the image.


Eventually worked out how to build a new version as above, and is now working perfectly for me :slight_smile:

Wonderful to hear @VintageRain. I haven’t found the time to apply it myself. Hope it will make it in the next release so others avoid the issue.

Would you mind sharing your compiled patched version? I've been trying all day without succes. It'd be very nice of you or anyone who can share a patched version of the kmod or the firmware.

Yep I can do that... I'll share a link. Bear in mind this is for the v4, is based on 19.07.4 and I can't accept any responsibility etc etc :joy: But I wish you luck! I just uploaded this using the LuCI web portal..


Thank you very much. You've really made my day :heart::heart: It worked well as expected for my Archer C50 v4 :heart:

1 Like

serious problem also with my c50v4 devices...
note though, e.g. netgear r6120 is NOT affected although it uses the same mediatek chip.

Thanks for creating a binary :). Do you have to delete your old configuration to install this patch? I installed the patch but it still says that radio0 is "Generic 802.11bgn" and I still get 1Mb speeds. I was able to confirm the hardware ID for mine is 0x7600.

dd if=/dev/mtd9 of=output.binary
hexdump -C /dev/output.binary
00000000 00 76 00 02 00 0c 43 e1 76 30 00 00 00 00 00 00 |.v....C.v0......|

Also big thanks to dtrautmann!

1 Like

I built a snapshot last night. In addition to the patch, it has zram-swap, zram-tmp, adblock, ddns, ipv6, and unbound built in. I removed any PPPoE packages, but there may be enough space to install using opkg.