Archer C2600 Connectivity drops

Hey Guys!

voodoo here,
here's the story, i have a TP-Link Archer C2600 working perfectly... except..
so i connected a wireless camera the other day and straight after I've experienced some connectivity issues on my phone (Exclamation mark next to the icon) which means there is no internet access but the device is connected to the wireless.
when i unplugged the wireless camera everything worked perfectly.

once again i plugged it in, and the same happen. while trying to investigate i saw lots of my wireless devices lost connectivity as well.
i tried to look for a duplicate mac address but there was no.

i have two other cameras from the same make. they both works perfectly and configured the same,
syslog / logread and kernel log didnt point to any issue.

can someone have an idea whats going on?


Some ideas:

  • Camera is flooding the network.
  • Camera has same IP address as router.
  • Camera is a DHCP server.

Same model, same hardware revision, same firmware revision?

any other leads?

exactly the same, except for MAC address :confused:

What do you see on the other devices? Do they lose connectivity to the router? Or do they keep connected but cannot reach internet?

Does it hapen only to wireless clients, on wired too?

they lose connectivity to the router i guess. i cant ping them.
the wired devices keep on working, but ill double check that tomorrow morning/

Just curious: Which camera exactly (Model)?
2.4 or 5GHz?

Wyzecam V2 flashed with dafang-hack to support rstp over 2.4ghz

Some more questions:

When you connect the camera to power, does it immediately connect via wireless and start an rtsp (or other) stream which is received $somewhere?

When the issue occurs, is only 2,4GHz affected or also 5GHz?

Does cam #3 work when you turn off one of cam #1 or cam #2?

How many other 2.4/5GHz wifi devices are connected to your router?

Which wireless driver have you installed?

@tmomas, thanks for you time,
yes, when the camera connected it immediately send the video stream to my synology so are the other cameras.
i tried to ping from the router when the issue happens and i saw extremely high latency

64 bytes from seq=541 ttl=64 time=4807.249 ms
64 bytes from seq=542 ttl=64 time=4463.242 ms
64 bytes from seq=543 ttl=64 time=3974.078 ms
64 bytes from seq=544 ttl=64 time=3355.726 ms
64 bytes from seq=545 ttl=64 time=2386.805 ms

thats when i saw a timeout on my pc. i guess the router can handle these amount of latency.

currenty there are about 45+ devices.
when i installed the openwrt for the first time it came with ath10k-ct but it kept telling me there are too many device (32) so i removed and install the original ath10k

that when i start notice different issue. like the one in this post.

the driver version is ath10k-firmware-qca99x0 - 20190416-1

so if anyone will look for a possible solution here's how i solved it

first i change the driver cfg file as below:

vdevs = 16
peers = 64
active_peers = 64
stations = 64

that helped with the "too many devices (32)" issue.
next i've change the 2.4ghz mode to N instead of Legacy

that helped with the connectivity drop i had when i connected the camera.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.