Archer c2600 - Cannot downgrade from 19.07 snapshot r10495-db5164d3d0

Dear openwrt community,

Looks like I'm in deep trouble ... unless you can help me :disappointed_relieved:

I have two Archer c2600 v1.1 set up as dumb Access Points with VLANs, firewall, dnsmasq,.. disabled, acc. to the tutorial.
Both AP's are running
OpenWrt 19.07-SNAPSHOT r10495-db5164d3d0 / LuCI openwrt-19.07 branch (git-19.242.20917-ae8ddb0).

I've spent the whole day to try reverting back to 18.06.4 (and 18.06 snapshot).
Every time I did a reset to default settings via Luci.

Unfortunately the following downgrade variants did not work, and I'm out of ideas and frustrated:

  1. Luci (many times)
  2. sysupgrade (-v -n) /tmp/...bin (many times)
  3. tftp on mac (mojave) (many times)
  4. tftp on linux (many times)
  5. tftpd64 on windows 10 (indicating it was uploaded 100%, twice, ArcherC2600..recovery.bin)

Due to wifi issues I had installed the 19.07 snapshot, based on feedback I got in the forum.
It works better than the 18.06.4, which was slower but not unstable, showing some syslog stuff (maybe after a few days it would have gotten an issue).

However, I thought going back to 18.06.4 to give it a second chance, also hoping for a soon 19.07 stable release.

What can I do to revert back to 18.06.4 ?

Many thanks in advance !

Cheers Blinton

sysupgrade -F -n your image.bin

Hi bricco1981,

Thanks for your quick recommendation.

Did it twice, on two different machines (shouldn't play a role), intentionally without resetting this time, verified sha256sum on the router.
-> No effect, snapshot 19.07 as well as the configuration remained. The -F should force, the -n should reset to defaults (?).
-> Tried also a newer 19.07 snapshot r10548... same result, still "read-only".

What is this file for ?

Many thanks in advance !

cheers Blinton

That is not really useful in your situation (only usable with serial console access for RAM booting).

There has been an issue with the sysupgrade refactoring recently (I don't know if that affected the openwrt-19.07 branch as well), but try testing sysupgrade -T /tmp/your_image.bin first.

        -T | --test
                     Verify image and config .tar.gz but do not actually flash.

It did, as the faulty procd version was backported to 19.07 before the bug materialised.

Specifically version r10495-db5164d3d0 (that you have in your two routers) was the faulty commit and the bug in procd was fixed in the next commit r10496-af7c186ead...

The r10495 has trouble sysupgrading away from it. (The fault symptom varies: my own routers were either bricked or remained at the same build.);a=commit;h=af7c186eadb704f79bcdc1f97bf3edf6ea88ff5c

The underlying fix for procd is that the ENV variable UPGRADE_BACKUP needs to be set:
setenv("UPGRADE_BACKUP", "/tmp/sysupgrade.tgz", 1);

I am not sure if it can be set manually at SSH console before you use the sysupgrade command from the same console, but maybe. Hopefully the author @rmilecki could provide you some advice how to circumvent that sysupgrade bug in procd.

(and there were some uninitialised variables fixed in procd, but those can't be changed via command line)

procd log leading to the bug (commits on 2019-09-04) and fix (commits on 2019-09-05):;a=shortlog;h=0f3c1366bb927e483abfae23dee0d15e26f87064

Alternatively you might try upgrading the procd package via opkg, but I am not sure if that works, as procd gets started so early that I am not sure if overlayfs is already active at that time. (and if procd updating is supported at all)

One way would be to use the built-in TFTP recovery mode or something like that (if your router contains that in u-boot), to flash the factory image.

Thanks a lot for your quick replies !

I was successful in tftp to tplink fw on both routers and then to 18.06.4.
Lets see whether everything works for a while :slight_smile:

cheers Blinton

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.