Archer c20 v4 - Stuck after flashing

I wish if you can help me with this
I flashed many devices and worked with OpenWRT on different devices successfully, however, stuck in:
Archer C20 v4 ~ Russian version

I followed the steps
with TFTP -> sent the firmware successfully
The device rebooted and stuck afterwards, LED blinks fast on ethernet connection, only .
Tried to set my IP to static and access with IP / SSH, 192.168.1.x no response
The device allows TFTP when powering on with reset button
Tried to flash back again stock firmware from TFTP (and did the "dd" command to make a stripped version of the firmware.. still the same)
Possible to guide me how to recover the device at this stage?

Do you have usb to serial connector? (CP2102 or PL2303 or something like that)

if so I can guide you to recover.

unfortunately. this model doesn't come with USB, the previous model has,
I have USB -> serial connector yes

for this method you have to open your router (go through some youtube teardown for this because I dint have this device)

strictly follow the steps below

after opening you should find some thing like TX RX GND (VCC dont use this VCC else you may fry your board)

  1. connect your serial connector TX --> RX in Router and RX in Serial connector to TX in router and GND to GND (dont power on the router) there is no need to solder just insert male breadboard pin in to it thats all it will connect

  2. connect your router with CAT5 ethernet cable to your pc ( here I am suggesting windows)

  3. download putty

  4. find the com port of the serial connector in device manager and enter the com(port number) in putty choose serial in putty with the speed 115200 click open

  5. configure tftpd server with computer ip as , bind to it, rename the openwrt-19.07.1-ramips-mt76x8-tplink_c20-v4-squashfs-tftp-recovery.bin to tp_recovery.bin and copy tp_recovery.bin to tftpd folder

  6. power on router press 4 continuously in the putty console (untill uboot stops for the command )

  7. enter the code below one by one

tftp 0x80060000 tp_recovery.bin
erase tplink 0x20000 0x7a0000
cp.b 0x80080000 0x20000 0x7a0000

if everyting ok then your device will boot up openwrt if not dont panic because the above code will not flash uboot, just copy paste boot log from putty console here will do my best.

if the above process is longer then connect with putty console and just copy paste the current boot log here will try to tell you what is the problem with the boot.

Thanks for your reply, the problem is I can't tear down the router as it still under warranty, I think I will replace it, I was hoping to fix this soft brick using tftp only (which is the only method working now)

Don't open your router

Tried to flash back again stock firmware from TFTP (and did the "dd" command to make a stripped version of the firmware.. still the same)
did you use this command to strip the firmware? dd if=orig.bin of=tplink.bin skip=1 bs=512
To prepare the recovery file cut the first 0x200 (that is 512) bytes from original stock image

If You want to install a OEM firmware.

1.Download the Original firmware from Tp-link
2.Download the XVI32 from
3.Open OEM firmware in XVI32
4.Select - edit - block (n) chars...
5. Select option hexadecimal and write $200 - OK
6. Select - edit - block delete
7.Select - file - save as - "name do You want".bin , example: tp_recovery.bin
then upload Stripped firmware via TFTP Server
That's it

1 Like

Hello David,
Thanks for your reply, Yes I tried and used DD and HXD as well, from original firmware I stripped the first 512 bytes
the router accepts tftp flashing using tftpd and reboots with all LEDs starting 1 second then nothing, and if I plugged ethernet LED flashes fast

One stupid question. Do you try as tp_recovery.bin both openwrt and stock image? In topic of Archer C5 v4 was interesting situation: openwrt tp_recovery.bin (prepared from openwrt image) was flashed good but stock tp_recovery.bin (prepared from stock image) failed as in your case.
Stock firmware was flashed in 2 steps.
First openwrt was installed. Then from openwrt command line stock firmware (specially prepared) was installed.

123serge123, yes I tried to flash openwrt image (both normal and stripped) in the beginning, but couldn't go to the command line to flash stock firmware / just the same error after it reboots: LEDs starting 1 second then nothing, and if I plugged ethernet LED flashes fast

I think that it's wrong way. Archer c20v4 uboot contain recovery commands:

set serverip
tftp 0x80060000 tp_recovery.bin;erase tplink 0x20000 0x7a0000;cp.b 0x80080000 0x20000 0x7a0000

As you see uboot skip uboot code before flashing.
So tp_recovery.bin must contain uboot code (or any empty 128k data as openwrt recovery image) at the begining.

Yeah you're right
it was my bad
thank you

Thanks sir it worked for me

Good to hear that :+1: and seems 5GHz works on this router with new image version

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.