Archer C20 v4 - No Internet

Hi guys,
I just managed to install OpenWrt. Now I can't connect to the Internet.

Where do I have to enter my username and password from my Provider? With the TP Link Interface I was using PPPoE connection type.

Thanks for your help.

From Luci GUI
Goto
Network->Interfaces->WAN

Select PPPoE for Protocol
And complete the remaining details

1 Like

I tried to enter my credentials, but I still can't get an internet connection

image

Check with your ISP what settings are required you maybe missing some steps.

Edit:

You may need to power off and wait about 15 minutes before reconnecting

I tried, but it doesn't work. I want to change back to the TP Link firmware using TFTP method.

But all my router lights keep flashing and I can't go back to the original firmware.

Can you help me please?

What does that mean, I don't understand the instructions.

image

1 Like

Are you referring to the picture?

If so, that's the command you enter on the serial console to reflash the factory firmware.

https://openwrt.org/toh/tp-link/tp-link_archer_c20_v4

There are unfortunately not explicit "return to stock" instructions there that I could see.

The instructions under https://openwrt.org/toh/tp-link/tp-link_archer_c20_v4#using_tftp_method will be close, but you should use the TP-Link firmware from the TP-Link site.

You need a stripped firmware:

Archer C20(EU)_V4_170822 (modified for TFTP flash)

https://drive.google.com/file/d/1EPy918sr0ilrjA4p3O5p14dePvuDRw6h/view?usp=sharing

Configure a computer with static IP 192.168.0.66/24 and a TFTP server.

Place tp_recovery.bin it in the tftp server's root directory.

Connect the computer to one of the router's Ethernet ports while the router is off. Press and keep pressed the router's reset button and power it up. After about 7-10 seconds release the reset button. The power LED will flicker rapidly for ~3 seconds, indicating download of the firmware file.

The router will write the firmware to flash during ~40 more seconds of occasional power LED blinks, and then will reboot by itself, ready for use.

In screenshot i see you get ip address, it is mean you successful connected to internet. You need try configure router. Connect to router via ssh with Putty. Than try "ping 8.8.8.8", show "route" command and "ifconfig".
Why did you decide that you do not have the Internet? Try made ping 8.8.8.8 from your PC, may be you just not get DNS server.

do you have the stripped/modified firmware now? link is not working!

This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.