Archer C20 cant enter config settings

I have an archer C20 v5 and I tried to install the openwrt via the router config page

After that my router started to blink and it didnt was working. After that happened I tried to install the factory firm via tftp, and apparentely worked. Now I tried to instal openwrt via tftp and apparentely wokerd(?)
My router connects to the internet but my pc doesn´t recognize the network, the wifi and everything is disabled and the only led is light up is the connected to the internet and the ethernet one(not even the power LED is on). Since my pc doesn´t recognize the network, I can´t see the gateway, and even if I type the 192.168.0.1 my pc doesn´t enter in the router config.

The openwrm really installed? How can I procced?

I don´t know if it matters, but it is the v5(BR)

That's expected if OpenWrt is installed.

Try https://192.168.1.1

If that doesn't work, take a look at your computer's IP address on the ethernet port (it should be directly connected to your C20v5's lan port). Let us know what you see there.


Tried that, but it is not working either, the broswer doesn´t connect

I don't see any IPv4 addresses there.

Is your computer directly connected via ethernet to the C20? Are there any other connections?

Yes, directly connected to the C20, no internet(no ethernet on the blue port)
I connected another router to the C20 via blue port and this showed up:


If i put these ips my pc just enter in the other router configs

If I used a wrong .bin file, my router would turn on? Is there any chance that this is happening because of it?

It's anybody's guess what would happen if you load the wrong file.

If in doubt, the best thing to do is to attempt to restore to the factory firmware. Download it from TP-Link's website and then use tftp to try to flash it to the router. This will get you generally running again and you can try OpenWrt again after that.

Instructions for both the install and the recovery are in the table of hardware page for your device. (you can use the firmware file that you download from TP-Link directly for tftp, no modifications required aside from possibly needing to change its name)

1 Like

trying to do it, but still the same problem, even with the factory firm from tp link
The router works, but I can´t connect to the router site to config it

Previously you had no ipv4 address on your computer. Do you have one now?

nope, the problem stills the same
No ipv4 even trying to reset o factory

after sending the original firm the router restarts but nothing happens after it, the problem persists

When you say it works, what does that mean? Sounds like it may be functioning as a switch if you have an upstream network, but I’d be very surprised if it is routing.

Yes, it was working like a switch. I´ve managed it to work by using the Linaro's build for open wrt. Don´t know if I can share the link from it here, but installing this build was more efficient then using the tplink firm from the website, apparently the original firms of this specific router are buggy with tftp.
After installing the Linaro's build I've updated it using the router page and everything now seems to be working! Thanks for the help

sorry to revive the post, but do you have any idea about how to decrease butterfly via wifi 5ghz?

I don’t know what you mean by “butterfly,” but since you are not using an official Openwrt build, you will need to ask the maintainer of the firmware that you do have installed.

1 Like

I updated to the official openwrt after installing the non official
I was trying to say bufferbloat, but for some reason my cellphine corrected to butterfly

1 Like

I'm not an expert on bufferbloat tuning, but you'll want SQM for that. Search the forums for other related threads.

Keep in mind that, depending on the expected total bandwidth, your device may struggle to deliver as SQM is quite processor intensive.