Archer C2: 2.4GHz (MT7620) support is broken

No. it won't boot if you import/save old settings. I don't know why
that image doesn't included mt7610e driver, but I think it may still have some problum with importing old config

Ah, I did indeed use "save old settings". I will try again, without saving settings. Thanks.

Before I reflash, can you just give me some info on what is baked in into this image? Is "dropping frame due to full tx queue" fixed in this this patch?

The reason I am asking is because everything works even in the old images, both 2.4GHz and 5GHz. It is just that 2.4GHz will fold during heavy traffic :frowning:


OK, I re-flashed and cleared settings and it booted fine! I had to manually re-enter settings through LUCI but it is a small price to pay. Unfortunately, 5GHz is gone but it was always rather short-range on Archer C2.

I will run this image couple of weeks and see if 2.4GHz folds during heavy traffic.


Hmm, it is marginally better but still broken.

I can still lock it at will with only two devices: file copy on laptop and Bandwidth Test on iPhone. It locks and I receive: " ieee80211 phy0: rt2x00lib_rxdone_read_signal: Warning - Frame received with unrecognized signal, mode=0x0001, signal=0x010a, type=4" in Kernel log. Traffic stops flowing (but WiFi device is still connected). Basically same problem but different error.

Also, 40MHz setting on 2.4GHz doesn't seem to work. It is one channel (20MHz) only regardless of setting.

Some info:

I have run various ports of both OpenWRT and LEDE on mutiple Archer C2 v1's I use as AP's.

All non-factory builds suffer from bug (?) that makes 2.4GHz WiFi freeze when exposed to high load.
Typically, kernel log will have entry "“phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue” and WiFi will stop responding until reboot (but you are still able to log into Luci via Ethernet).

I have even tried newest build based on OpenWrt 18.06 trunk (linked here: Archer C2: 2.4GHz (MT7620) support is broken)

According to information, this issue should have been fixed in 18.06 but it is still present, albeit in another form. Now kernel will log " ieee80211 phy0: rt2x00lib_rxdone_read_signal: Warning - Frame received with unrecognized signal, mode=0x0001, signal=0x010a, type=4" prior to WiFi locking instead.

So either Archer C2 2.4GHz hardware has built-in flaw or there is something wrong with WiFi driver for MT7620A

I'm using Archer C50 which also hosts the same chipset MT7620 and affected by the slow 2.4Ghz bug.
Are you able to find the solution?? 18.06 is meant to solve the issue for our devices but it didn't help.

I do not know if we are talking the same bug? 2.4GHz isn't slow. I was able to hit 7MB/s (megabytes). Key to this was enabling 40MHz channels and disabling legacy speeds.
The main problem is that if router is subjected to hi load (streaming from local NAS, for example) WiFi would freeze and stop sending packets. Device will still be connected to WiFi but there will be no traffic.
You are still able to log on via Ethernet and reboot though.

If you just use router for surfing the net via DSL, you will probably never saturate WiFi enough to knock it offline, but any "power user" will make it fold.

Hi, at least for me, selecting 40Mhz thru luci didn't work, i had to enable it by editing /etc/config/wireless manually thru ssh, and then it did use 40Mhz, even then, 2.4 Ghz seems slow compared to the stock firmware, also, selecting the minimum power did help devices use higher link speeds, especially for me given that i live on an apartment building where 2.4 Ghz Wi-Fi it's congested af!

As for the locking under heavy load, it's the same for me, and having 100Mbps of download means every time some device loads something heavy it crashes the Wi-Fi

PD: i use the C2 as a dumb AP same as Guntruck

You are right, it is impossible to force it to 40MHz. Even setting "option htmode HT40+" in etc/config/wireless does not make wireless use two channels.:frowning:

MT7620 support is broken and I believe 5GHz is only way to use this router under LEDE/OpenWRT (not working under 18.06, unfortunately).

Regarding the bug: something has been done in 18.06 as router will survive "full tx queue" but will lock at "ieee80211 phy0: rt2x00lib_rxdone_read_signal: Warning - Frame received with unrecognized signal, mode=0x0001, signal=0x010d, type=4" instead :(:laughing:

I just got it to lock by copying a file from NAS. Checked through SSH, CPU was hovering around 12% while copying so obviously, CPU is not the issue.

I am considering switching back to factory firmware.

Unfortunately, Factory firmare without Open VPN, ad block, transmission, Vlans, Fast samba shares & Unlimited freedom is hard to live with.
Hope somebody can fix this famous bug on MT7620 once and for all. :frowning:

40MHz bug should be fixed for a while in master or 18.06 snapshots.

I am using following version and 40MHz is not functioning: OpenWrt 18.06-SNAPSHOT r6910+16-80c28554f2 / LuCI Master (git-18.143.28733-7acacf2)

It should have been fixed a long time ago

Sadly, No
Currently using the latest snapshot of June 2nd.

If you really need to run LEDE/OpenWRT on C2, I recommend reverting back to 17.01. 5GHz works fine and without freezing. Just switch off (or rename) 2.4GHz.

Only issues are no KRACK-patches and shorter range.

OK, I just reverted back to:
LEDE Reboot 17.01-SNAPSHOT r3889-a0af7c8c59 / LuCI lede-17.01 branch git-18.098.72829-575e327), Kernel Version 4.4.126

5GHz is rock solid, and very quick with 40MHz channels. Unfortunately, LuCI does not talk to 5GHz driver well so there is basically no info on 5GHz clients. But device works perfect.

2.4GHz is as flaky as it ever was (even in 18.06).

So for now, my plan is to disable 2.4GHz and run with 5GHz on all AP's. As range is bad, I will try to configure 802.11r Fast Transition and let device roam between 5GHz islands.

Or I might just get more C2's to fill in the voids :slight_smile:

Update: got roaming to work according to info in this Reddit post

Curiosity: I opened one of my AP's (bricked, tried to se-solder flash chip).
Archer C2 does not have dedicated 5GHz antenna! There is a place for it on PCB but no hardware (copper antenna). PCB strips leading to it do not have components. It seems that 5GHz RF feed is load-balanced into one of two 2.4GHz antennas instead, to save money! :joy::laughing:

I can confirm this still happens with 18.06.0-rc2

Hi again :wink:

A 1/4 wavelength (lambda) for 2.4 GHz (desired length) is still a 1/2 wavelength (or 2/4s) for 5.8 GHz. Definetly high impedance but this isn't as bad for 20dBm (100mW) as it would be for 37dBm (5000mW) :slight_smile: It's like "dualband antennas" for ham radios. A single/multiple of "lambda/4" is desired.

corrected antenna length for 2.4 GHz (2400000kHz): lambda/4 = ((300000 / 2400000) / 4) * .95

...which equals 2.97cm :smiley: