(Archer A9 v6 EU) Help in reverting from openwrt to tp-link stock firmware


Decided last year to try out openwrt (current ver. OpenWrt 22.03.2 r19803) on an Archer A9 v6 EU eventhough I researched the forum and found out that 2.4Ghz will not currently work but still went through since it enabled me to use VPN.

Started using multiple IoT devices that need 2.4Ghz... Can't see/connect on current 5Ghz SSID...Decided to revert to tp-link firmware.

Searched around and didn't find a definitive solution (ex:stripping firmware) does not work as its returning a 0 kbs file. Neither did other services or dead online sources. Even doing the power + reset button 5-10sec did not help since it reverted to default blank openwrt save but tried it anyway.
TFTP didn't work either (neither saw nor found any logs or traffic)...

Other info that I can include is perhaps that even if its reverting after the physical reset process I found out I initially saved it with a different non 192.x.y.z. IP range so probably that's why settings the TFTP procedure via standard LAN adapter to did not connect anything in the TFTP server? Not bricked, still functional.
What am I doing wrong? And cheers mates!

this is usually due to TFTPd host firewall, or wrong IP.

this works for uboot recovery only, and the specific IP is a must.

Forgot to mention that I allowed it through both windows defender and my other firewall as everything was set to OFF.

Shall I set the IP pool to regular and try again?

.66 is to be set on the TFTPd host. the device assumes it's the IP of the TFTPd.

I have. Step-by-step as it was clearly described here yet I didn't manage to do anything with TFTP. Tried multiple times and followed the log viewer tab with no result.

TLDR, but this is wrong


you need to make sure you select the interface with the 66 IP.
but the TFTPd will shift back to, when/if the router is restarted, so you might need to put some other network device between the A6 and the computer, like a switch or router.

thank you for the idea. Will try to find a spare somewhere around here and will give it a go and return with the results

Just tried this method and it didn't succesfully work.
Did manage to get to transfer yet I always receive a timeout:
Unfortunately having not being able to succesfully transfer to whole .bin file, it just reverted to the same openwrt img state.

there's nothing about stripping the fw in the flash and revert info, at https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=9c335accfe57f3049850b8fdb684c9e7e5feea82

great...that means that I have no existing revert option leaving this router only 5Ghz...

you're missing the point.

since it's not in there, you might not need to strip it ?

Then how may go about this in order to return it to stock?